summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 19:09:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 19:11:17 +0100
commitfaf4c6df1a18873cb04eba93e0e23e9584ca157e (patch)
treec207e99a2ee3f4fadd2513ffa069b8fcb54f41a6 /dev-python/hpack
parentdev-python/h2: Remove old (diff)
downloadgentoo-faf4c6df1a18873cb04eba93e0e23e9584ca157e.tar.gz
gentoo-faf4c6df1a18873cb04eba93e0e23e9584ca157e.tar.bz2
gentoo-faf4c6df1a18873cb04eba93e0e23e9584ca157e.zip
dev-python/hpack: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest1
-rw-r--r--dev-python/hpack/hpack-3.0.0-r1.ebuild44
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild40
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
index 5a78d6f92ee8..854dd72c0ae9 100644
--- a/dev-python/hpack/Manifest
+++ b/dev-python/hpack/Manifest
@@ -1,2 +1 @@
-DIST hpack-3.0.0.tar.gz 5305971 BLAKE2B d1df8a1b2a1ce8b91e63cab475d3957f937fb74c0bec343d342971be1bb7cfbc929c53cf041845df2965cef0cfb098345bf0612acabc7ef3e5e23f6f0aa44f2f SHA512 7b9cf5e643dff2a6454bfe419b797c8ed1a0fe6ec3b725d2696da5a820ab96fe87a64e600b1831c7024bd82616b155a0aa058301acb32172155b6538ba0a73c6
DIST hpack-4.0.0.tar.gz 5301419 BLAKE2B 0164f6aafc0d1f17f6c397efe710503a22501faae3c7dbba4e57ca2dc76e4d373bc5e65bf55acda8bc61975d12f8a2084de0e0c4587539e5a3102e3cf66d562b SHA512 f482d086d7a82649393e3cfea55c98966ce57055cb1826bc4dec1ea334661c02708e7903f2e8e588ee1c30df41373e1de9fb960c2e7bbc18d0ace0b8f97b195b
diff --git a/dev-python/hpack/hpack-3.0.0-r1.ebuild b/dev-python/hpack/hpack-3.0.0-r1.ebuild
deleted file mode 100644
index 5ce4b72bd759..000000000000
--- a/dev-python/hpack/hpack-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python HPACK header compression"
-HOMEPAGE="
- https://python-hyper.org/projects/hpack/en/latest/
- https://github.com/python-hyper/hpack/
- https://pypi.org/project/hpack/
-"
-SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# dev-python/pytest-relaxed causes tests to fail
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
- !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
-)
-
-EPYTEST_DESELECT=(
- # relies on outdated exception strings
- test/test_table.py::TestHeaderTable::test_get_by_index_out_of_range
-)
-
-EPYTEST_IGNORE=(
- bench
-)
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
deleted file mode 100644
index 5486b7db607d..000000000000
--- a/dev-python/hpack/hpack-3.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python HPACK header compression"
-HOMEPAGE="
- https://python-hyper.org/hpack/en/latest/
- https://pypi.org/project/hpack/"
-SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# dev-python/pytest-relaxed causes tests to fail
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
- !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
-)
-
-python_test() {
- local deselect=(
- # relies on outdated exception strings
- test/test_table.py::TestHeaderTable::test_get_by_index_out_of_range
- )
-
- epytest hpack test ${deselect[@]/#/--deselect }
-}