summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2023-01-19 19:55:40 +0100
committerStephan Hartmann <sultan@gentoo.org>2023-01-19 20:26:01 +0100
commit79a6a1e3b984e2dab75d1e7fec3ff812edec4b3d (patch)
tree5a8a69a29b20f88f942121bdb96537491de2a590 /dev-python/hidapi
parentdev-libs/hidapi: add 0.13.1 (diff)
downloadgentoo-79a6a1e3b984e2dab75d1e7fec3ff812edec4b3d.tar.gz
gentoo-79a6a1e3b984e2dab75d1e7fec3ff812edec4b3d.tar.bz2
gentoo-79a6a1e3b984e2dab75d1e7fec3ff812edec4b3d.zip
dev-python/hidapi: add 0.13.1
Closes: https://bugs.gentoo.org/891171 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'dev-python/hidapi')
-rw-r--r--dev-python/hidapi/Manifest1
-rw-r--r--dev-python/hidapi/hidapi-0.13.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/hidapi/Manifest b/dev-python/hidapi/Manifest
index 03f65d02f5e7..6b9ab75aecb9 100644
--- a/dev-python/hidapi/Manifest
+++ b/dev-python/hidapi/Manifest
@@ -1 +1,2 @@
DIST hidapi-0.12.0.post2.tar.gz 125008 BLAKE2B 6792d8a4bbd80da19b3dd1fde47061e3a0f00678059e36598da4a34142cbfe1e732854c2a372a869891be79e1131a7cef138913556159574f10b8b08439bfefe SHA512 dee9f1f07e4f297b935c8e3fbe798471f449f6a101d68131db23d24ccfb5ce445cc3b0e7305606d3630443a817aa75a27093109078735168a59d21614606f0a0
+DIST hidapi-0.13.1.tar.gz 130169 BLAKE2B 127e622e4b85880f1c20ccb819b806c66357d8cfa6c15d370c13a6a0a3838ac6acf0673c7edbf5309a91f55051b6177800328b8f897ff43cd1e0af1b511c52a6 SHA512 8e6a7a6bf47e24f6f637cc036dc306518d893fc9fdf94639f626725e8f8767d7e85496d8db5f9f394d648ef5af4dd5ead0f0a6d452a019b5d9fa0716371febed
diff --git a/dev-python/hidapi/hidapi-0.13.1.ebuild b/dev-python/hidapi/hidapi-0.13.1.ebuild
new file mode 100644
index 000000000000..fe4ec8ca7aa0
--- /dev/null
+++ b/dev-python/hidapi/hidapi-0.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Cython interface to HIDAPI library"
+HOMEPAGE="https://github.com/trezor/cython-hidapi"
+MY_PV=$(ver_rs 3 .post)
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="|| ( BSD GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND=">=dev-libs/hidapi-$(ver_cut 1-3)"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_configure_all() {
+ DISTUTILS_ARGS=( --with-system-hidapi )
+}
+
+python_test() {
+ epytest tests.py
+}