summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-15 11:50:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-15 11:52:34 +0100
commita696dd39837a5138964bf9b5f00ad24534ba1336 (patch)
treea72915fdd4d7f00a8753fd61411e34d50eab9a79 /dev-python/hatch-vcs
parentdev-python/pexpect: Remove old (diff)
downloadgentoo-a696dd39837a5138964bf9b5f00ad24534ba1336.tar.gz
gentoo-a696dd39837a5138964bf9b5f00ad24534ba1336.tar.bz2
gentoo-a696dd39837a5138964bf9b5f00ad24534ba1336.zip
dev-python/hatch-vcs: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/Manifest1
-rw-r--r--dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch32
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild38
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/hatch-vcs/Manifest b/dev-python/hatch-vcs/Manifest
index db6cd674215e..217ef9dd6465 100644
--- a/dev-python/hatch-vcs/Manifest
+++ b/dev-python/hatch-vcs/Manifest
@@ -1,2 +1 @@
-DIST hatch-vcs-0.3.0.gh.tar.gz 10049 BLAKE2B 69f49e205b4e42b46a246cc2403d8e7bbd2b8f83a360f1100ba98ecf7308d445e265749bd1f5fa7cca84104436e2643fd3f95292f2dba3dc48584a0df5136136 SHA512 ce22937aae8130a485ab154378f6c58c1720d66d277349a95ccfb58fd748deb69cd17d34ec3a12f3201f9e348e5d5b1c6b977432e614bb42d0e3065ec5f7f9c6
DIST hatch-vcs-0.4.0.gh.tar.gz 10822 BLAKE2B 92b1ad1181a6bae815a6d01045836976b8767086f2a7001de9ad97f0d61737895da9a411419e28c5b2d830fca606d7d9c21265210965bc7691670f92aeab1b22 SHA512 bf40cc371c8d8e120fce83e5986fc2bdc2087fa5a4ac4a407d32617e98205ded79dcb29a00c7638ba68dd5ce09f31e84b34176627a6a34dfb7708031f4c4519a
diff --git a/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch b/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch
deleted file mode 100644
index 919036acd720..000000000000
--- a/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 47364faf5563df0eaa631ed10383817762c6b547 Mon Sep 17 00:00:00 2001
-From: Ben Beasley <code@musicinmybrain.net>
-Date: Thu, 5 Jan 2023 18:49:54 -0500
-Subject: [PATCH] Work with setuptools_scm 7.1 (fix #25) (#26)
-
-Make test_write less brittle (see also #8, #9) so that it works with
-_version.py files generated by at least setuptools_scm 7.1, 7.0, and
-6.x.
----
- tests/test_build.py | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test_build.py b/tests/test_build.py
-index 2fde601..7c76343 100644
---- a/tests/test_build.py
-+++ b/tests/test_build.py
-@@ -75,8 +75,10 @@ def test_write(new_project_write):
- assert os.path.isfile(version_file)
-
- lines = read_file(version_file).splitlines()
-- assert lines[3].startswith(('version =', '__version__ ='))
-- assert lines[3].endswith("version = '1.2.3'")
-+ version_starts = ('version = ', '__version__ = ')
-+ assert any(line.startswith(version_starts) for line in lines)
-+ version_line = next(line for line in lines if line.startswith(version_starts))
-+ assert version_line.endswith(" = '1.2.3'")
-
-
- @pytest.mark.skipif(sys.version_info[0] == 2, reason='Depends on fix in 6.4.0 which is Python 3-only')
---
-2.39.1
-
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
deleted file mode 100644
index b79b4f409c3b..000000000000
--- a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Hatch plugin for versioning with your preferred VCS"
-HOMEPAGE="
- https://pypi.org/project/hatch-vcs/
- https://github.com/ofek/hatch-vcs/
-"
-SRC_URI="
- https://github.com/ofek/hatch-vcs/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/setuptools-scm-6.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-vcs/git
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-Work-with-setuptools_scm-7.1-fix-25-26.patch
-)
-
-distutils_enable_tests pytest