summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/happydoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/happydoc')
-rw-r--r--dev-python/happydoc/Manifest1
-rw-r--r--dev-python/happydoc/files/happydoc-3.1-python-2.6.patch28
-rw-r--r--dev-python/happydoc/files/happydoc-3.1-setup.py158
-rw-r--r--dev-python/happydoc/happydoc-3.1-r2.ebuild40
-rw-r--r--dev-python/happydoc/metadata.xml8
5 files changed, 235 insertions, 0 deletions
diff --git a/dev-python/happydoc/Manifest b/dev-python/happydoc/Manifest
new file mode 100644
index 000000000000..39c0d60b4837
--- /dev/null
+++ b/dev-python/happydoc/Manifest
@@ -0,0 +1 @@
+DIST HappyDoc_r3_1.tar.gz 732849 SHA256 ef5f8dee5782a1ebe750aa51b855ce84097f5bb60488826ea5da900098c5aaec SHA512 5f526f90225f189f59fdca24b3db1cd73c7346b859cc3b8a00ddaf248c2e0901ad048c1a83ec1b9ee3f950f1260427b0fd1d6f4b1e6c4b772615f6ca799f86ff WHIRLPOOL 63ec714e882b6f067002a46e07a38ec83649e61bbc2a5dfaf83ab0e13d05e289e8e7b7d25434daa126bbb2bec2298b0c15b3120be00c5b831a763fb7379aba87
diff --git a/dev-python/happydoc/files/happydoc-3.1-python-2.6.patch b/dev-python/happydoc/files/happydoc-3.1-python-2.6.patch
new file mode 100644
index 000000000000..4cced8e25833
--- /dev/null
+++ b/dev-python/happydoc/files/happydoc-3.1-python-2.6.patch
@@ -0,0 +1,28 @@
+--- happydoclib/CommandLineApp.py
++++ happydoclib/CommandLineApp.py
+@@ -102,10 +102,21 @@
+ #
+ # Exception names
+ #
+- ReservedOptionName = 'Reserved option name'
+- HelpRequested='Help requested'
+- InvalidOptionValue='Invalid value for option'
+- InvalidArgument='Invalid argument to program'
++ class ReservedOptionName(ValueError):
++ 'Reserved option name'
++ pass
++
++ class HelpRequested(ValueError):
++ 'Help requested'
++ pass
++
++ class InvalidOptionValue(ValueError):
++ 'Invalid value for option'
++ pass
++
++ class InvalidArgument(ValueError):
++ 'Invalid argument to program'
++ pass
+
+ #
+ # Globally useful configuration stuff.
diff --git a/dev-python/happydoc/files/happydoc-3.1-setup.py b/dev-python/happydoc/files/happydoc-3.1-setup.py
new file mode 100644
index 000000000000..56ae38388f7c
--- /dev/null
+++ b/dev-python/happydoc/files/happydoc-3.1-setup.py
@@ -0,0 +1,158 @@
+#!/usr/bin/env python
+#
+# $Id$
+#
+# Time-stamp: <02/02/05 10:00:12 dhellmann>
+#
+# Copyright 2001 Doug Hellmann.
+#
+#
+# All Rights Reserved
+#
+# Permission to use, copy, modify, and distribute this software and
+# its documentation for any purpose and without fee is hereby
+# granted, provided that the above copyright notice appear in all
+# copies and that both that copyright notice and this permission
+# notice appear in supporting documentation, and that the name of Doug
+# Hellmann not be used in advertising or publicity pertaining to
+# distribution of the software without specific, written prior
+# permission.
+#
+# DOUG HELLMANN DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT SHALL DOUG HELLMANN BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+"""Distutils setup file for HappyDoc
+
+"""
+
+__rcs_info__ = {
+ #
+ # Creation Information
+ #
+ 'module_name' : '$RCSfile: happydoc-3.1-setup.py,v $',
+ 'rcs_id' : '$Id$',
+ 'creator' : 'Doug Hellmann <doug@hellfly.net>',
+ 'project' : 'HappyDoc',
+ 'created' : 'Sat, 03-Feb-2001 12:51:26 EST',
+
+ #
+ # Current Information
+ #
+ 'author' : '$Author: neurogeek $',
+ 'version' : '$Revision: 1.1 $',
+ 'date' : '$Date: 2009/02/25 20:59:36 $',
+}
+try:
+ __version__ = __rcs_info__['version'].split(' ')[1]
+except:
+ __version__ = '0.0'
+
+#
+# Import system modules
+#
+from distutils.core import setup
+import string
+import sys
+
+#
+# Import Local modules
+#
+
+#
+# Module
+#
+
+BSD_LICENSE="""
+
+ Copyright 2001, 2002 Doug Hellmann.
+
+ All Rights Reserved
+
+Permission to use, copy, modify, and distribute this software and
+its documentation for any purpose and without fee is hereby
+granted, provided that the above copyright notice appear in all
+copies and that both that copyright notice and this permission
+notice appear in supporting documentation, and that the name of Doug
+Hellmann not be used in advertising or publicity pertaining to
+distribution of the software without specific, written prior
+permission.
+
+DOUG HELLMANN DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+NO EVENT SHALL DOUG HELLMANN BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+"""
+
+LONG_DESCRIPTION = """
+ HappyDoc is a tool for extracting documentation from Python source
+ code. It differs from other such applications by the fact that it
+ uses the parse tree for a module to derive the information used in
+ its output, rather that importing the module directly. This allows
+ the user to generate documentation for modules which need special
+ context to be imported.
+"""
+
+
+def cvsProductVersion(cvsVersionString='$Name: $'):
+ """Function to return the version number of the program.
+
+ The value is taken from the CVS tag, assuming the tag has the form:
+
+ rX_Y_Z
+
+ Where X is the major version number, Y is the minor version
+ number, and Z is the optional sub-minor version number.
+ """
+ cvs_version_parts=string.split(cvsVersionString)
+ if len(cvs_version_parts) >= 3:
+ app_version = string.strip(cvs_version_parts[1]).replace('_', '.')
+ if app_version and app_version[0] == 'r':
+ app_version = app_version[1:]
+ else:
+ app_version = 'WORKING'
+ return app_version
+
+
+
+if sys.platform == 'win32':
+ platform_specific_scripts = ['happydocwin.py']
+else:
+ platform_specific_scripts = ['happydoc']
+
+setup (
+ name = 'HappyDoc',
+ version = cvsProductVersion(),
+
+ description = 'HappyDoc Automatic Documentation System',
+ long_description = LONG_DESCRIPTION,
+
+ author = 'Doug Hellmann',
+ author_email = 'doug@hellfly.net',
+
+ url = 'http://happydoc.sourceforge.net',
+ licence = BSD_LICENSE,
+
+ platforms = ('Any',),
+ keywords = ('documentation', 'extraction', 'source', 'docstring', '__doc__'),
+
+ packages = [ 'happydoclib',
+ 'happydoclib.docset',
+ 'happydoclib.docstring',
+ 'happydoclib.docstring.StructuredText',
+ 'happydoclib.parseinfo',
+ 'happydoclib.parsers',
+ ],
+
+ package_dir = { '': '.' },
+
+ scripts = platform_specific_scripts,
+ )
+
diff --git a/dev-python/happydoc/happydoc-3.1-r2.ebuild b/dev-python/happydoc/happydoc-3.1-r2.ebuild
new file mode 100644
index 000000000000..d34a29859cba
--- /dev/null
+++ b/dev-python/happydoc/happydoc-3.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 versionator
+
+MY_PN="HappyDoc"
+MY_PV=$(replace_all_version_separators "_" ${PV})
+MY_V=$(get_major_version ${PV})
+
+DESCRIPTION="Tool for extracting documentation from Python source code"
+HOMEPAGE="http://happydoc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
+
+LICENSE="HPND ZPL"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+# Tests need extra data not present in the release tarball.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}${MY_V}-r${MY_PV}"
+
+python_prepare_all() {
+ cp "${FILESDIR}/${P}-setup.py" setup.py || die "Copying of setup.py failed"
+ epatch "${FILESDIR}/${P}-python-2.6.patch"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( srcdocs/${MY_PN}${MY_V}-r${MY_PV}/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/happydoc/metadata.xml b/dev-python/happydoc/metadata.xml
new file mode 100644
index 000000000000..cf257c2d740d
--- /dev/null
+++ b/dev-python/happydoc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">happydoc</remote-id>
+ </upstream>
+</pkgmetadata>