summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-24 01:11:59 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-24 01:11:59 +0100
commitaef0e289bb46a8ae8a49640c0ddd1cc1e3323fdd (patch)
tree0e9d2eb30f676d4a8ea528173f9fe501d8d0e1f7 /dev-python/guessit
parentdev-python/boto3: Bump to 1.16.43 (diff)
downloadgentoo-aef0e289bb46a8ae8a49640c0ddd1cc1e3323fdd.tar.gz
gentoo-aef0e289bb46a8ae8a49640c0ddd1cc1e3323fdd.tar.bz2
gentoo-aef0e289bb46a8ae8a49640c0ddd1cc1e3323fdd.zip
dev-python/guessit: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/guessit')
-rw-r--r--dev-python/guessit/Manifest1
-rw-r--r--dev-python/guessit/guessit-3.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/guessit/Manifest b/dev-python/guessit/Manifest
index 7c2572a027b8..301b399768d2 100644
--- a/dev-python/guessit/Manifest
+++ b/dev-python/guessit/Manifest
@@ -1 +1,2 @@
DIST guessit-3.1.1.tar.gz 147605 BLAKE2B 3b11747b652e922aada12ce771c1e91e8842c78c221ac39c068488ae6cae95ebc6d9f6d8849aaef11d522e2c7d6e6f8e34981179e48d9db649e811c5fa2e52ef SHA512 6a02c4024d286cf49c62e072bcb616a052cec1ce51d364b17cea1768504c4ecebba914a3bf5beda9a61dca0e7764c8642cb5b918a20fb25cdd7120ad1667825f
+DIST guessit-3.2.0.tar.gz 147286 BLAKE2B 0ab249eb82204fd58a6d6c960b11b2009a3055ae91a91c244192a2bd9832e7356f444a6b4291cf56d55a4c9a1cd0ccec22d527114d61f9f5888a8439918ba6bc SHA512 5eaa0ad8cdf60812bebf10af51f62095baa70f48b66a052002fceb0d705daab3b8bcd2cb0fc3d18b63b9f4aa8118b9d85283bebdcfdb8ed4204e1b7e2b5ae78c
diff --git a/dev-python/guessit/guessit-3.2.0.ebuild b/dev-python/guessit/guessit-3.2.0.ebuild
new file mode 100644
index 000000000000..ddba17cae041
--- /dev/null
+++ b/dev-python/guessit/guessit-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit
+ https://pypi.org/project/guessit/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}