summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-02 11:48:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-02 13:22:36 +0200
commit3c63a336bd1e72719a54697e81bc3e15da4dc841 (patch)
tree2ef14f118c56fae9348994a53026450e67c2bca3 /dev-python/griffe
parentdev-python/vobject: Bump to 0.9.8 (diff)
downloadgentoo-3c63a336bd1e72719a54697e81bc3e15da4dc841.tar.gz
gentoo-3c63a336bd1e72719a54697e81bc3e15da4dc841.tar.bz2
gentoo-3c63a336bd1e72719a54697e81bc3e15da4dc841.zip
dev-python/griffe: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-1.3.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index b8973904a449..01ab11e14c0b 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1,2 +1,3 @@
DIST griffe-1.3.0.gh.tar.gz 383337 BLAKE2B e1908e68f812b9227f4ba7249a8f20ae1d75cac3237ca90c5f47adb51a8d0efcd31b016f30f9f9e0af2a2292b86cf5fb08d9314e72ca4282bd36cafce19030ac SHA512 839d0bb8fc36f5552d50721f72905d533849d9b7258ba1ed1eabc783dddc4aee87ea612605bd23268f4282c06e71e010e76dfebce0951ef92917abc80211e7d1
DIST griffe-1.3.1.gh.tar.gz 383076 BLAKE2B e7bc85daa49531c17215ce64209db89c3e4c12fe7b20a7ba004ee696c1fa0307a1753c7663d455ac6562b226c6526725750c0b25c2e148af468431d1a38d8aad SHA512 45d44cc81ca3e108127470271f058dcfaa80702ed4e5d2610a9b4f6bb5e1e16052c9ae5c6a5b396b1cc8d6002b9cf3531cae611b15e7d54b1096d74b4bf04976
+DIST griffe-1.3.2.gh.tar.gz 383330 BLAKE2B ce96d0ce14dec7a48172758cb08331e07b36c436f953061aee375fbb7c4ad7fa01050b6a15335dae44d292c90ea5724c85abda9b4f8dd231e979ca1b8d2faa38 SHA512 098f78f95e89d22738ef5b8b6e91fffd7f0c48705492081aee0c072d2ac409f88bb7698ffbcbbfa9cd7627d081c441a8eafba3d261a81dba02a92e04ac80d7c0
diff --git a/dev-python/griffe/griffe-1.3.2.ebuild b/dev-python/griffe/griffe-1.3.2.ebuild
new file mode 100644
index 000000000000..b3ab8d048238
--- /dev/null
+++ b/dev-python/griffe/griffe-1.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/backports-strenum-1.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)