summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-12 15:26:04 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-12 16:52:07 -0500
commitaed9457afed12f70edb3a2eac25d2debdf529ff4 (patch)
treee6f2a8ef7e57211d7ebe92f6d103a653a1dbf9e8 /dev-python/graphviz
parentdev-python/py-gfm: 0.1.4 bump (diff)
downloadgentoo-aed9457afed12f70edb3a2eac25d2debdf529ff4.tar.gz
gentoo-aed9457afed12f70edb3a2eac25d2debdf529ff4.tar.bz2
gentoo-aed9457afed12f70edb3a2eac25d2debdf529ff4.zip
dev-python/graphviz: 0.10.1 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest1
-rw-r--r--dev-python/graphviz/graphviz-0.10.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 4a5091f4f5ca..22013e4f9cf1 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1 +1,2 @@
+DIST graphviz-0.10.1.zip 167590 BLAKE2B 4ca344cffe042bd16de56c15ae8056805e7ea82c88b0a9b535cc42d77038d1b54f1f4102630df3b3961e2edf7ab36e2cab75aea6a73a98c603609e0df82ab1fd SHA512 49366190fd3bd703c3d85a9220a63e5a667dc35a41037a54167f3ba96098945b2331294ece4ab260d7006b260cfdd0558b007768fb5f51aededf0b2c0d302eff
DIST graphviz-0.7.1.zip 100779 BLAKE2B b981953160f1978fe62b6c2cf422fcde78cc4de80a5274fd6e59c15f8907b34c68b0413d2c538d507d43bd8761349cd7fe532744d2e5ad737f403e52e1fca7b2 SHA512 e8ba326060ff3039f74902c01cf3d96c9965ce2259d0d5a9594e399added05c7e25b0f6c4b0be9ab21c1d37bbfb69e9c4856a7bb457b545185d48838d34cac70
diff --git a/dev-python/graphviz/graphviz-0.10.1.ebuild b/dev-python/graphviz/graphviz-0.10.1.ebuild
new file mode 100644
index 000000000000..7e92809d7b77
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.10.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die
+}