summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-07 07:04:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-07 07:04:52 +0100
commit353fa24fe2fbc2dd62b9f063a3865828664aa387 (patch)
tree7b6ab1d0d91a5f630acd58564beaf8d1a5464505 /dev-python/google-auth
parentdev-python/magic-wormhole-mailbox-server: Bump to 0.5.0 (diff)
downloadgentoo-353fa24fe2fbc2dd62b9f063a3865828664aa387.tar.gz
gentoo-353fa24fe2fbc2dd62b9f063a3865828664aa387.tar.bz2
gentoo-353fa24fe2fbc2dd62b9f063a3865828664aa387.zip
dev-python/google-auth: Bump to 2.36.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.36.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index c836748da8b9..6f3f7b791351 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1 +1,2 @@
DIST google_auth-2.35.0.tar.gz 267223 BLAKE2B d30c8ca15f0e8183c1d50c285d578d8373bf722dddbeb2d5e423b2e25b26f038d406a6dccacf2cebbb0741a2ef07e8b0c86d0362734db3a56054ff76b6d213d7 SHA512 5c359bb94f213812c57cc2c2942d1da3aa08f0e73dde6f5b6c2f563fb51056009f3b821ec0fc39571221da267011d850c242a5ab044d88648be44759f7337973
+DIST google_auth-2.36.0.tar.gz 268336 BLAKE2B cb9df17eb367ef9be27abacb29b481490e4a471311befa2c269031b888f0a7a804b4c41a30f8914f05f3ee60e9b9664e3c694a24509418c64374d23c40cc3666 SHA512 9e61d5ab21e8973f6d9d2af8d4b73e5637efe9b09b1854bf82743e4a03a6b5fc6154a492e4b7ad5935ba3796186d6ed11e891bd0a0eb1190e06fedc824904c22
diff --git a/dev-python/google-auth/google-auth-2.36.0.ebuild b/dev-python/google-auth/google-auth-2.36.0.ebuild
new file mode 100644
index 000000000000..5778ba5b4f5d
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.36.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}