summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/gmpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/gmpy')
-rw-r--r--dev-python/gmpy/Manifest2
-rw-r--r--dev-python/gmpy/gmpy-2.0.4.ebuild60
-rw-r--r--dev-python/gmpy/gmpy-2.0.6.ebuild69
-rw-r--r--dev-python/gmpy/metadata.xml17
4 files changed, 148 insertions, 0 deletions
diff --git a/dev-python/gmpy/Manifest b/dev-python/gmpy/Manifest
new file mode 100644
index 000000000000..73a279d5ed44
--- /dev/null
+++ b/dev-python/gmpy/Manifest
@@ -0,0 +1,2 @@
+DIST gmpy2-2.0.4.zip 280459 SHA256 c2b06e75d876960adabce575f01361f96884a64401740af49e8b9ef356bbbecf SHA512 98f57a0b140bb352dc1403dc799845685d52d346e87e6402d1e10c8ef46bbe90bae598143bd2ebffedb617c0519f75590a6cc9b30d887dc08ff6d5ae4fd7ec75 WHIRLPOOL 2f9c903c91c864ef4eb7e02b4004204580af1b7ddf67c67719ab68506a95cf57af64e06bed24ef445eb7eb2de0e7ef550748ac6e8b41e10297fcc22b04cfbca9
+DIST gmpy2-2.0.6.zip 280353 SHA256 5041d0ae24407c24487106099f5bcc4abb1a5f58d90e6712cc95321975eddbd4 SHA512 fae7952e86c821d8a4ae083a54d6e7e3516459abbf9bcb16408ea0d7989f309aa27348bb51781e0f52466eaf121cb193b54f5f4453093f022ce8394d273196a0 WHIRLPOOL d9a301d5d5f0872ddb517bba815cefaf8c2a3a1fa7e3e0b38f0ea0d2ec1ef8e0526549f8a3d4713b35a878125f1a766bbd3c31e0eb27902266bf3ae8a8dc2559
diff --git a/dev-python/gmpy/gmpy-2.0.4.ebuild b/dev-python/gmpy/gmpy-2.0.4.ebuild
new file mode 100644
index 000000000000..fff5836262a0
--- /dev/null
+++ b/dev-python/gmpy/gmpy-2.0.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
+HOMEPAGE="http://code.google.com/p/gmpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="amd64 ~arm ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc mpir"
+
+RDEPEND="
+ >=dev-libs/mpc-1.0.2
+ >=dev-libs/mpfr-3.1.2
+ !mpir? ( dev-libs/gmp:0= )
+ mpir? ( sci-libs/mpir )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex mpir --mpir --gmp)
+ )
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cd test || die
+ ${PYTHON} runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gmpy/gmpy-2.0.6.ebuild b/dev-python/gmpy/gmpy-2.0.6.ebuild
new file mode 100644
index 000000000000..330810815c1e
--- /dev/null
+++ b/dev-python/gmpy/gmpy-2.0.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
+HOMEPAGE="http://code.google.com/p/gmpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc mpir"
+
+RDEPEND="
+ >=dev-libs/mpc-1.0.2
+ >=dev-libs/mpfr-3.1.2
+ !mpir? ( dev-libs/gmp:0= )
+ mpir? ( sci-libs/mpir )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ # rm non std test file
+ rm test*/gmpy_test_thr.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex mpir --mpir --gmp)
+ )
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cd test || die
+ "${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
+ if python_is_python3; then
+ cd ../test3 || die
+ else
+ cd ../test2 || die
+ fi
+ "${PYTHON}" gmpy_test.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gmpy/metadata.xml b/dev-python/gmpy/metadata.xml
new file mode 100644
index 000000000000..f60e7204ca7a
--- /dev/null
+++ b/dev-python/gmpy/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ gmpy2 is a C-coded Python extension module that supports
+ multiple-precision arithmetic. gmpy2 supports the GMP multi-precision
+ library, the MPFR (correctly rounded real floating-point arithmetic) and MPC
+ (correctly rounded complex floating-point arithmetic) libraries.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">gmpy2</remote-id>
+ </upstream>
+ <use>
+ <flag name="mpir">Use <pkg>sci-libs/mpir</pkg> as gmp implementation</flag>
+ </use>
+</pkgmetadata>