summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 18:43:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 18:43:49 +0300
commit9e284d0611cf59f13bf956ac6fb84b337f9aeb75 (patch)
treea90a5009e5e128ee725a270cb13520e0c9131c66 /dev-python/flask
parentdev-python/debtcollector: Stabilize 2.5.0 ALLARCHES, #838640 (diff)
downloadgentoo-9e284d0611cf59f13bf956ac6fb84b337f9aeb75.tar.gz
gentoo-9e284d0611cf59f13bf956ac6fb84b337f9aeb75.tar.bz2
gentoo-9e284d0611cf59f13bf956ac6fb84b337f9aeb75.zip
dev-python/flask: drop 2.0.1, 2.0.1-r1, 2.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest2
-rw-r--r--dev-python/flask/flask-2.0.1-r1.ebuild51
-rw-r--r--dev-python/flask/flask-2.0.1.ebuild47
-rw-r--r--dev-python/flask/flask-2.0.2.ebuild58
4 files changed, 0 insertions, 158 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index ea8224884dfb..b94accd176f3 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,5 +1,3 @@
DIST Flask-1.1.4.tar.gz 635920 BLAKE2B c1f19e7449177ecf6e901d5932ad25cbe866ff53b9323f717541922b1ea5b10203ff07630fcf3eabaedd9b6a24ef031ad2aaa2e2f759925363bebfa7e5d967da SHA512 6f427a1264921b8560446afacee2757d16de0dc22d6ed249b7bc5d6f50f3af50c89b79ce900d75b41af4befc53910f2b532c2e280de42837e2133acb6b1bd80d
-DIST Flask-2.0.1.tar.gz 626851 BLAKE2B 05273edacd6d66237a552410df7ef7ff367e28c273cc89f654eac5ed2eb3d26f71437169905372b398cc6c5c5067dcbea54aa1cab782e03c6186ac9ae3949f4c SHA512 fefed4971f0542b25ba2867919aa54a83b6e3f47e7cee94586543843e7e00ba209ac15d8fe28a3c53981f587aebcf2f3915a49e1a9cd1b729099dccbed3783c2
-DIST Flask-2.0.2.tar.gz 628479 BLAKE2B 13555ce0602e685b5fe29ba51e05534263d70440c56c9096e95e0893e010d877154d3d1db1bff47209e6b70e91612a71e8aed149a067465f9e3a11486d843a86 SHA512 341be4e453dd5f682e465af356ff85ffe76f52a62e529e6cd251f95199e73b0f93414af093f899f61721e9bb351f09972a433a55beacc972b5e577b86e003081
DIST Flask-2.0.3.tar.gz 629304 BLAKE2B dae5ffb86b9f57ea95c682be4f858faec6432c877695c06fff40a056cd7eedff25cf120458435b634954f0e65e57ad6c22c3eb6b5ed751b6d7f5d4501358c240 SHA512 b759ada3ab610d4893cd48f6de070c23929ab2e37af863238912fa19246acfb399b1e67576bf6112c9bb56b00002792d28c7538c65b026f31bcc6f64305ae966
DIST Flask-2.1.0.tar.gz 630852 BLAKE2B 6a67d4c0f67aebf326493d86baefcdfb5d1e1b36a3b6a2e818d8bd92d84267ca8762ee0af3e70254bd4ce53a4f781edc9560e6408adf8ac285b308cdf1103c0f SHA512 8d9da72e3ad7df378a32fc40290e9499bc79eb3167235e8497f8f2753ac2c9da170d34f0ae3e87db99ba8282c887a479a64b680818b668bc13e033e6e5603926
diff --git a/dev-python/flask/flask-2.0.1-r1.ebuild b/dev-python/flask/flask-2.0.1-r1.ebuild
deleted file mode 100644
index 80d79167579b..000000000000
--- a/dev-python/flask/flask-2.0.1-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log_cabinet
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-2.0.1.ebuild b/dev-python/flask/flask-2.0.1.ebuild
deleted file mode 100644
index 4f3c5218d025..000000000000
--- a/dev-python/flask/flask-2.0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-2.0.2.ebuild b/dev-python/flask/flask-2.0.2.ebuild
deleted file mode 100644
index d3e04db93a7b..000000000000
--- a/dev-python/flask/flask-2.0.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://github.com/pallets/flask/"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/click-7.1.2[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log_cabinet
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # https://github.com/pallets/flask/issues/4292
- # (test xfailed in newer version)
- tests/test_cli.py::test_lazy_load_error
- )
-
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}