summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 18:25:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 18:25:52 +0100
commit043affe8677994f8e782fa952217a6f13c56da7c (patch)
treec3cf8815a6cf80461f1390f2979b8c2b9e30da9e /dev-python/flask-paranoid
parentdev-python/mecab-python: Enable py3.11 (diff)
downloadgentoo-043affe8677994f8e782fa952217a6f13c56da7c.tar.gz
gentoo-043affe8677994f8e782fa952217a6f13c56da7c.tar.bz2
gentoo-043affe8677994f8e782fa952217a6f13c56da7c.zip
dev-python/flask-paranoid: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paranoid')
-rw-r--r--dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild b/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
index 953ab140b834..dcdd7dd4cc61 100644
--- a/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
+++ b/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Simple user session protection extension for Flask"
-HOMEPAGE="https://github.com/miguelgrinberg/flask-paranoid/"
+HOMEPAGE="
+ https://github.com/miguelgrinberg/flask-paranoid/
+ https://pypi.org/project/Flask-Paranoid/
+"
SRC_URI="
https://github.com/miguelgrinberg/flask-paranoid/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -19,6 +22,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
distutils_enable_tests unittest