summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-01 09:16:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-01 09:50:42 +0100
commit83b12f8860ee2721aafead0f49f1c68027d9c89b (patch)
treeabfdb470add212d7099007acc34633930b03f859 /dev-python/flask-paginate
parentdev-python/pikepdf: Bump to 2.5.2 (diff)
downloadgentoo-83b12f8860ee2721aafead0f49f1c68027d9c89b.tar.gz
gentoo-83b12f8860ee2721aafead0f49f1c68027d9c89b.tar.bz2
gentoo-83b12f8860ee2721aafead0f49f1c68027d9c89b.zip
dev-python/flask-paginate: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.8.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index 7a48d44bb85e..9857adce9b85 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1,2 +1,3 @@
DIST flask-paginate-0.7.0.tar.gz 119358 BLAKE2B 24c1f3bc77853c9c96bb72d3364e73845f8fd0870606dd96b4261861430bef864a6830dd793f4f6e8a9371c89342dda88c5f976d79ff4a1bec7d687614b2014a SHA512 11c335c08c6a9c32999e5b8ba7a76c1fb04769e5ab679b550efc87497446edbaa1e3ccb62a4c238a0b5585f7ba4067e43f158ae123c3b118db84b90cb5d4f219
DIST flask-paginate-0.8.0.tar.gz 119687 BLAKE2B 0c73f1d72938fe2cb322ec53e1ce3df083c81f1b2bc58f150af1e602c7e435aaa844534283f83337cd9840f8ece69620de9e63e3f8017f848b5dc2fb54f19848 SHA512 1958dbf5675b24ae175098c740e08cc3aa9d2088f6f10768083a740fba3a87cf4b5255ddbc5fe72d286fb04817f527fba9fca5b09af2929851c5ac1eefe3b4d7
+DIST flask-paginate-0.8.1.tar.gz 119751 BLAKE2B 954d39e13619784b1a79abc9f26fc2b3827309f9a3b77cacdd40c8f8d9dfec4c2967894e2d571e26841245da6d264dad71a412e425c87aa0c07b3520274de7c4 SHA512 ca226c79bd944a19760048c1289b554ee048f4f8d1f231f5545423843b7c0616d52ee8024cc68628e11c5f528972897d7fdb1630f87063bbd0e40c4dacf91224
diff --git a/dev-python/flask-paginate/flask-paginate-0.8.1.ebuild b/dev-python/flask-paginate/flask-paginate-0.8.1.ebuild
new file mode 100644
index 000000000000..04652ff0b78d
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.8.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
+}