summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 15:35:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 15:35:05 +0200
commit3c0ef721e846179b047526aec45c778ec830756e (patch)
treebbecb7cccf4a44a86a6cf36a02ae34097b64bae0 /dev-python/flask-gravatar
parentdev-python/fitsio: Enable py3.10 (diff)
downloadgentoo-3c0ef721e846179b047526aec45c778ec830756e.tar.gz
gentoo-3c0ef721e846179b047526aec45c778ec830756e.tar.bz2
gentoo-3c0ef721e846179b047526aec45c778ec830756e.zip
dev-python/flask-gravatar: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-gravatar')
-rw-r--r--dev-python/flask-gravatar/flask-gravatar-0.5.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/flask-gravatar/flask-gravatar-0.5.0.ebuild b/dev-python/flask-gravatar/flask-gravatar-0.5.0.ebuild
index 705f58dabfa9..25ccf70909aa 100644
--- a/dev-python/flask-gravatar/flask-gravatar-0.5.0.ebuild
+++ b/dev-python/flask-gravatar/flask-gravatar-0.5.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PN="Flask-Gravatar"
MY_P=${MY_PN}-${PV}
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Small extension for Flask to make usage of Gravatar service easy"
@@ -32,5 +32,5 @@ src_prepare() {
python_test() {
cd tests || die
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ epytest
}