summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/elementtree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/elementtree')
-rw-r--r--dev-python/elementtree/Manifest1
-rw-r--r--dev-python/elementtree/elementtree-1.2.6-r3.ebuild39
-rw-r--r--dev-python/elementtree/metadata.xml5
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/elementtree/Manifest b/dev-python/elementtree/Manifest
new file mode 100644
index 000000000000..4c9d78d37224
--- /dev/null
+++ b/dev-python/elementtree/Manifest
@@ -0,0 +1 @@
+DIST elementtree-1.2.6-20050316.tar.gz 41752 SHA256 b29d5f2417cb331562c8c5f8ebef2a895ba540261c4245f526143c6a31bccb04 SHA512 f213cf5bd9a79b59a2033c652d9d53087fd07dd3550db1771b8ba97168c3a5722d31ac5ff8699830df0f14a1d9f0caf8d237e8c6153568e16347d8b212771baf WHIRLPOOL d68e7e2cf02753c0d982406c4df01272c2fd1ec784bfb097d09a363fe36b4a73b7b8b9af07b0069b409e810ed5075e10419cc0ce86a21e5065621a7a12acb5d4
diff --git a/dev-python/elementtree/elementtree-1.2.6-r3.ebuild b/dev-python/elementtree/elementtree-1.2.6-r3.ebuild
new file mode 100644
index 000000000000..acdc6dce7c53
--- /dev/null
+++ b/dev-python/elementtree/elementtree-1.2.6-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P="${P}-20050316"
+
+DESCRIPTION="A light-weight XML object model for Python"
+HOMEPAGE="http://effbot.org/zone/element-index.htm http://pypi.python.org/pypi/elementtree"
+SRC_URI="http://effbot.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="ElementTree"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s/distutils.core/setuptools/" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/elementtree/metadata.xml b/dev-python/elementtree/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/elementtree/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>