summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-26 00:16:54 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-29 15:09:44 +0800
commit402a716ea4b4225934f487e55d028c9d00fe96b9 (patch)
tree7cf55ad47ea452f3947968192263ba8456f96544 /dev-python/dominate
parentnet-misc/stunnel: Stable for HPPA (bug #578938). (diff)
downloadgentoo-402a716ea4b4225934f487e55d028c9d00fe96b9.tar.gz
gentoo-402a716ea4b4225934f487e55d028c9d00fe96b9.tar.bz2
gentoo-402a716ea4b4225934f487e55d028c9d00fe96b9.zip
dev-python/dominate: new package, dependency of flask-bootstrap, vn. 2.2.0
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1353 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/dominate')
-rw-r--r--dev-python/dominate/Manifest1
-rw-r--r--dev-python/dominate/dominate-2.2.0.ebuild33
-rw-r--r--dev-python/dominate/metadata.xml20
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
new file mode 100644
index 000000000000..745db7c5f1a5
--- /dev/null
+++ b/dev-python/dominate/Manifest
@@ -0,0 +1 @@
+DIST dominate-2.2.0.tar.gz 23320 SHA256 318063a9b600cdc13f84592ad515db0fd3a2816a2433e2a2fad55a5398ae05da SHA512 416fa8ac56856aa06d547a307cdf46ca71b3a29caf36103e78a2522973e407cab90c0163a34fd8ed724586a6121bbd8f4822da78dbf1f77c18e9106aab112e74 WHIRLPOOL 9d5e8516d90b947c88c76e39b0ca73ff07737e36dd9336bd70f73fe5f3836d0fc43f28a7c1343e880367a449a117a1fdfa7e48c8b35f502ba20950b328f62c3b
diff --git a/dev-python/dominate/dominate-2.2.0.ebuild b/dev-python/dominate/dominate-2.2.0.ebuild
new file mode 100644
index 000000000000..764995fe66bc
--- /dev/null
+++ b/dev-python/dominate/dominate-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+COMMIT="acb02c7c71e353e5dfbc905d506b54908533027e"
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+# Releases aren't tagged on GitHub, tests are missing from PyPI
+# https://github.com/Knio/dominate/pull/69
+SRC_URI="https://github.com/Knio/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/dominate/metadata.xml b/dev-python/dominate/metadata.xml
new file mode 100644
index 000000000000..3f517fafb3d4
--- /dev/null
+++ b/dev-python/dominate/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">dominate</remote-id>
+ <remote-id type="github">Knio/dominate</remote-id>
+ <bugs-to>https://github.com/Knio/dominate/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API. It allows you to write HTML pages in pure Python very concisely, which eliminate the need to learn another template language, and to take advantage of the more powerful features of Python.
+ </longdescription>
+</pkgmetadata>