summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-19 23:21:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-19 23:59:35 +0100
commit438c77957b72cf1f66fa8a0bf14cb22d036207a0 (patch)
tree3721651d1680249e05b6f6ac25c8349b7053e1c5 /dev-python/dogpile-cache
parentapp-admin/awscli: Bump to 1.22.39 (diff)
downloadgentoo-438c77957b72cf1f66fa8a0bf14cb22d036207a0.tar.gz
gentoo-438c77957b72cf1f66fa8a0bf14cb22d036207a0.tar.bz2
gentoo-438c77957b72cf1f66fa8a0bf14cb22d036207a0.zip
dev-python/dogpile-cache: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dogpile-cache')
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.1.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 883a646e7611..9b4f4e535497 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1 +1,2 @@
DIST dogpile.cache-1.1.4.tar.gz 390117 BLAKE2B 88c38473c3f177a42c2e336f7913940cde5f793245ddbb2ce3e7569c0853a1f93138a4987dc7781490132f84beb17c568ec9fc9a955201123842ccdbdfff2fc4 SHA512 d70f0ad1097f7de5bc887cfd0835f02a10bd6096433d39e6fe2fad5ed294f019ee043ced670c08bacb8ad1f6cf32ada36a62149a9b6db6205e72f49fa68bf4c4
+DIST dogpile.cache-1.1.5.tar.gz 392536 BLAKE2B 062392cda9b06da889f924bc04743faa133b978a908ffdbc1e9cc9a2a9a69db22ee26b27c7cb2ec2dedee20786cf90c6d02d163731224956091b2d3baa25774b SHA512 b6d453121ef8e58da60478e2e1e2db57804dfa3b17cceeace930ba75d159629dfba4b5d63c50fbbc2eafeadbfcd6e1e4cbe22c8da1f54c90473f8ee677d764f8
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.1.5.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.1.5.ebuild
new file mode 100644
index 000000000000..0f50911455b1
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value"
+HOMEPAGE="https://github.com/sqlalchemy/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest