summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-04 04:18:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-04 05:13:47 +0200
commite63ec97e7ac22e15d1ce7c18bc53bc455df40fcc (patch)
treed18b7bb852e35214591241288f5076a178a8fc41 /dev-python/django
parentdev-python/django: Bump to 5.0.9 (diff)
downloadgentoo-e63ec97e7ac22e15d1ce7c18bc53bc455df40fcc.tar.gz
gentoo-e63ec97e7ac22e15d1ce7c18bc53bc455df40fcc.tar.bz2
gentoo-e63ec97e7ac22e15d1ce7c18bc53bc455df40fcc.zip
dev-python/django: Bump to 4.2.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest2
-rw-r--r--dev-python/django/django-4.2.16.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index 89a247f4d2c6..2e4323279114 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -1,5 +1,7 @@
DIST Django-4.2.15.checksum.txt 2418 BLAKE2B 06338f990952736d1368c11bc0a14df4fcb756c7e33b0a843d692c1ca23a9bf5073c552513cf2846c16da24da475ff122f59122f90da528c2cb8875072fa7748 SHA512 b4e8eb163a889c2aa556217b2ba6280916c891b2f8af862d66e09b5ec643dee9281e58e2382fdfdee1d0e1a9a80267c93993374ae3e0f33f3ec5051bae69f145
DIST Django-4.2.15.tar.gz 10418066 BLAKE2B 4abf7205995fbc8dd90ca43aadfdd6737c5f731fea4054f987ae851e0b6f0a5f0f799441f94ca322e31c07c2a810903a00b4432b71a7517b2a261c4844ddba90 SHA512 8f334dcaa36b3bce5184ddf1a1508bf42614be6ab486c9e0d87e9bfd212511c43081ad5fb02d2dd7b54f8236fc1f7ee9cd7b7f6f94ac8edc1cb52d1c0c698880
+DIST Django-4.2.16.checksum.txt 2584 BLAKE2B c4808af742372d281b391a511fd32904cf56b87603fea5b8ee03e48b1c55d64f03c196fbfbee5b652ef08be6304cd7d2ab9b11535f3d368fbe03f6b8e3cc1b40 SHA512 f031b4beb360ba5184bdb8fa5ee35c0c7b779abb08ecb61b175965450345d3fa3d99f2862b5be7a0b5887ef42c7e65dde0506ede855cdd25e1992cea50847d1a
+DIST Django-4.2.16.tar.gz 10436023 BLAKE2B 67a35f9f625d10fe4bdaff8365532468a76a37ce04a9baf4b6140092b2fb5e2dcb164dbd70e313db3ab567ebd44ebaf3f55a47e12c50c765cf5518968ad63f67 SHA512 a4abe599af711f745f24a559943f67a168cd40f6c7345f2188817e748f9a463e434c463426ca99b80fdaa5580423248c35ff4fcfd35f3364abdf5279094e3f5c
DIST Django-5.0.8.checksum.txt 2408 BLAKE2B 18751733d7abaa4e98039bf0cfa3773a999df4351371939803ec77850c25d75392abc7e4136e8c4a79620017c224bafcd8552c2446ee0817249abebcc3b0e1bb SHA512 c05027bdec0928dd51239ba5c72b97b737ad73dbbdbdc1c4bef2b9faf8afc188cd854e1dcd3b5ffbdc9c3a30dea5a27e4b899f9d257bcee6f80fbfdfd30e7a20
DIST Django-5.0.8.tar.gz 10630791 BLAKE2B 0a5408b46b69b701f3ff88717b41b22cd4abd776a0b46f46025febd423e4b9c5f395da50a5be9e479bc0047405330231da400f3f2324bbb69ca5ab07966bc168 SHA512 b835d01f76f0e0082f299c2b15483aa3a8aef79f873b09dac546d3b4ecfa8a6fb84d9377e06e18a858bd24bcdd2db89c4cf05811b3af133b7da6609f6c2d917c
DIST Django-5.0.9.checksum.txt 2574 BLAKE2B e3bef5a7fdfa8a383cc1d185dff3e8818dee0005f6cd8e16866bee6990c8b3687c31ca2df67be29033b706e1dea86495b0e74c18d3cb0c6fec563085ffaa3497 SHA512 00e16ce374ebb02966bc7b00a207a5635c36173950ef230f3f8c70a2ddfa59d9a8dd6827f3dbb1c7aeb0da5f14dd39430a2d1bacd00fa80d02e2610ad76a7bbe
diff --git a/dev-python/django/django-4.2.16.ebuild b/dev-python/django/django-4.2.16.ebuild
new file mode 100644
index 000000000000..4a334aecaf30
--- /dev/null
+++ b/dev-python/django/django-4.2.16.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 multiprocessing optfeature verify-sig
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="
+ https://www.djangoproject.com/
+ https://github.com/django/django/
+ https://pypi.org/project/Django/
+"
+SRC_URI="
+ https://media.djangoproject.com/releases/$(ver_cut 1-2)/${P^}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/python/django-4.2.8-pypy3.patch.xz
+ verify-sig? ( https://media.djangoproject.com/pgp/${P^}.checksum.txt )
+"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.3.1[${PYTHON_USEDEP}]
+ sys-libs/timezone-data
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ )
+ verify-sig? ( >=sec-keys/openpgp-keys-django-20240807 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/django-4.0-bashcomp.patch
+ "${WORKDIR}"/django-4.2.8-pypy3.patch
+ # https://code.djangoproject.com/ticket/35661
+ "${FILESDIR}"/django-5.1-more-pypy3.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/django.asc
+
+src_unpack() {
+ if use verify-sig; then
+ cd "${DISTDIR}" || die
+ verify-sig_verify_signed_checksums \
+ "${P^}.checksum.txt" sha256 "${P^}.tar.gz"
+ cd "${WORKDIR}" || die
+ fi
+
+ default
+}
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite \
+ -v2 --parallel="${EPYTEST_JOBS:-$(makeopts_jobs)}" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature_header "Additional Backend support can be enabled via:"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:0
+ optfeature_header
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+}