summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-29 08:51:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-29 10:06:35 +0200
commiteb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7 (patch)
tree75a0a8216b692be07a0b7b5eb405f978caaf44ce /dev-python/django-otp/django-otp-1.0.6.ebuild
parentdev-ruby/parser: add ruby30 (diff)
downloadgentoo-eb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7.tar.gz
gentoo-eb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7.tar.bz2
gentoo-eb6f6d09594b7b0d7cf2baf51443f9e3a047e7a7.zip
dev-python/django-otp: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-otp/django-otp-1.0.6.ebuild')
-rw-r--r--dev-python/django-otp/django-otp-1.0.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-otp/django-otp-1.0.6.ebuild b/dev-python/django-otp/django-otp-1.0.6.ebuild
new file mode 100644
index 000000000000..26c9a4b8f2af
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}