summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:13:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:15 +0200
commitc5f82a77d139013524013d5dc8feefc41ab7c724 (patch)
treec2dcd25561c37ca702f8f938027592b168ad880d /dev-python/dill
parentdev-python/pytools: Bump to 2022.1.8 (diff)
downloadgentoo-c5f82a77d139013524013d5dc8feefc41ab7c724.tar.gz
gentoo-c5f82a77d139013524013d5dc8feefc41ab7c724.tar.bz2
gentoo-c5f82a77d139013524013d5dc8feefc41ab7c724.zip
dev-python/dill: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest1
-rw-r--r--dev-python/dill/dill-0.3.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 4635e25b6cd2..8ed203cb53cf 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1 +1,2 @@
DIST dill-0.3.4.gh.tar.gz 152875 BLAKE2B 61c638f0459b94f5cc0dabd9d5fd224c3c010ab6ccc9b7e47943922e7e139bd74c7a5173657febb028fc79632792f807586e271316ad87bb505520163f85a300 SHA512 1b1991909a9782382ecdb2ada13249c8b446d3558de69501280c816f7cd6c6728f9d3303c826461245ab9e42c43c02e4605142f25e09244bb7ccc9ca68a4b565
+DIST dill-0.3.5.gh.tar.gz 161213 BLAKE2B 305aabe868b7718b57199a29fdb3ec4a28c797d36be458bb182f909ef39f15bc016779b2f08a1804c0eab6c940a2d5baef26d1c34bb4c9a0d0687674265bff96 SHA512 3bcaf692e98f2495aad9af44815c33ac9c64ea7c946f41a8d37851b63fc2c94bbcbc4a923559e2433971a900a34daf404f9461ba28b38657dd908a84b9f0b8d6
diff --git a/dev-python/dill/dill-0.3.5.ebuild b/dev-python/dill/dill-0.3.5.ebuild
new file mode 100644
index 000000000000..7c162ac2dcdf
--- /dev/null
+++ b/dev-python/dill/dill-0.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ local fail= t
+ for t in tests/test_*.py; do
+ ebegin "\t${t}"
+ "${EPYTHON}" "${t}"
+ eend ${?} || fail=1
+ done
+
+ [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}