summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/demjson
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/demjson')
-rw-r--r--dev-python/demjson/Manifest3
-rw-r--r--dev-python/demjson/demjson-1.6.ebuild42
-rw-r--r--dev-python/demjson/demjson-2.2.2.ebuild36
-rw-r--r--dev-python/demjson/demjson-2.2.3.ebuild36
-rw-r--r--dev-python/demjson/metadata.xml5
5 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/demjson/Manifest b/dev-python/demjson/Manifest
new file mode 100644
index 000000000000..d9917c95f89c
--- /dev/null
+++ b/dev-python/demjson/Manifest
@@ -0,0 +1,3 @@
+DIST demjson-1.6.tar.gz 64299 SHA256 1d989c310e33569ecc178b8182e53bde8f748bf5ea10cfbc0e331f8c313f6e29 SHA512 aad21fb11998fc2bd6d9ce6cf3be448d0cb6636716109384dcf268aa3b5c6e37f20e579e51d72e554de3e9e4857b7ea850727009bf72bf020ee0f305e3c258f9 WHIRLPOOL efef0bd9e180b52c8d176e65302f0e9850cd30e8eae28323e7a3abe60319a81f1f1f5019ba5835937544816bea8965746276b6597dce610224193dfc5d415a65
+DIST demjson-2.2.2.tar.gz 130874 SHA256 5114563dd3a0324b6c9c74250528660adbb6a095b2a015038149e31a9b5727d5 SHA512 c5df57fdc286b33fbceada0ff8531d559fb183b29ca114fbfef7dfd0615ad5bae3882da91b6818ad58be5e20d3c2091db7cb75b1c31285b8ed5f466984b5fc15 WHIRLPOOL 6ca4e599128a896df098514d2b1983b025122ac07ee5ffa2f673c2d441482e32b7fa013a3896c2efedfcea9114dbe2049927b1754d4db9127bdf1ab9f32ddda3
+DIST demjson-2.2.3.tar.gz 131263 SHA256 9fb0f3c02fe500104680af2889a64d1637b395aebdb37341ae2309d77854f40c SHA512 058f8429967e21b30a9e28ec7790c372f5eb3126d7ab05c17d6f0548002650314048bf2f4eb3e2c8f75bb91169722c90eeeddb815ca166dfb14b2d1385504b14 WHIRLPOOL b665e19c5c28afd4636b2f33959f7a14d04706c8e8d7c77ef790fb12e3aff56a1cea35420caf7eceb06de8b001cab07a3e38d4252b7f67a3dbba99fcc4f1d476
diff --git a/dev-python/demjson/demjson-1.6.ebuild b/dev-python/demjson/demjson-1.6.ebuild
new file mode 100644
index 000000000000..28953531ef66
--- /dev/null
+++ b/dev-python/demjson/demjson-1.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ http://pypi.python.org/pypi/demjson"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DOCS="AUTHORS.txt CHANGES.txt NEWS.txt THANKS.txt docs/*.txt"
+PYTHON_MODNAME="demjson.py"
+
+src_test() {
+ cd test
+
+ testing() {
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" test_demjson.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml docs/*.html || die "Installation of documentation failed"
+ fi
+}
diff --git a/dev-python/demjson/demjson-2.2.2.ebuild b/dev-python/demjson/demjson-2.2.2.ebuild
new file mode 100644
index 000000000000..5ce72c9cddf9
--- /dev/null
+++ b/dev-python/demjson/demjson-2.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ http://pypi.python.org/pypi/demjson"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Docs are .txt files
+ if use doc; then
+ dodoc docs/*.txt || die "Installation of documentation failed"
+ fi
+}
diff --git a/dev-python/demjson/demjson-2.2.3.ebuild b/dev-python/demjson/demjson-2.2.3.ebuild
new file mode 100644
index 000000000000..69d0794ca93f
--- /dev/null
+++ b/dev-python/demjson/demjson-2.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="encoder, decoder, and lint/validator for JSON (JavaScript Object Notation) compliant with RFC 4627"
+HOMEPAGE="http://deron.meranda.us/python/demjson/ http://pypi.python.org/pypi/demjson"
+SRC_URI="http://deron.meranda.us/python/${PN}/dist/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ cd test
+ if python_is_python3; then
+ 2to3 -w --no-diffs test_demjson.py
+ fi
+ "${PYTHON}" test_demjson.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Docs are .txt files
+ if use doc; then
+ dodoc docs/*.txt || die "Installation of documentation failed"
+ fi
+}
diff --git a/dev-python/demjson/metadata.xml b/dev-python/demjson/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/demjson/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>