summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2023-02-09 21:08:50 +0300
committerSergey Popov <pinkbyte@gentoo.org>2023-02-09 21:09:18 +0300
commitcefde26f81bd9b8ef6f9ecb08f9a0efc0322ec6a (patch)
tree65f9529fe3284e7500e1ef67738d343219b81e0e /dev-python/cx_Freeze
parentdev-java/mockito: Stabilize 4.11.0 x86, #893766 (diff)
downloadgentoo-cefde26f81bd9b8ef6f9ecb08f9a0efc0322ec6a.tar.gz
gentoo-cefde26f81bd9b8ef6f9ecb08f9a0efc0322ec6a.tar.bz2
gentoo-cefde26f81bd9b8ef6f9ecb08f9a0efc0322ec6a.zip
dev-python/cx_Freeze: version bump
Closes: https://bugs.gentoo.org/892706 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'dev-python/cx_Freeze')
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.14.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index f12780ddaa16..5a9dc4704f75 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1 +1,2 @@
DIST cx_Freeze-6.13.1.gh.tar.gz 1486207 BLAKE2B aa0151fed482714e41a859059f9672950249ad7fe50fa2accaa9d6af7ddc183a8f74d87337f274849a34a404dda0c732300343b58cd872f3bd03bf275c2f4d97 SHA512 48d569fdce5c6cb100232ce3577f0a55a40f3d1dcafa884a4d62af7f27200a21eb892504b47fb7cd106f410354b70d98a8e5245382431bc1f6d990510c77cb36
+DIST cx_Freeze-6.14.2.gh.tar.gz 1647508 BLAKE2B 7b14a75a21dbeb360c61609e9ac018c6e8bba6ffb357781cc2d8d27cd3cc27e054587845d117ce25912cd57b3fe83c037e5b76f55cd593890f66056ff18039df SHA512 40158afb0e2291c4a2f161eb2ef733fc8a2107c620dcf87f812bb0f6b81bfd06e3ec1b4108333c7d43a4855605621745395e765a825a68f3dd62b3edc21fc3c3
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.14.2.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.14.2.ebuild
new file mode 100644
index 000000000000..93c422b0d59a
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.14.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="
+ https://cx-freeze.readthedocs.io/
+ https://github.com/marcelotduarte/cx_Freeze/
+ https://pypi.org/project/cx-Freeze/
+"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ virtual/libcrypt:=
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # new setuptools?
+ tests/test_command_bdist_rpm.py::test_bdist_rpm
+)