summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-27 19:02:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-27 19:46:48 -0500
commit73562e494634c4105234c49d78a34b6162b9f4fc (patch)
treed6630f43eefcf39e8969247314926e158548be8e /dev-python/cursive
parentdev-python/WSME: 0.9.2 bup (diff)
downloadgentoo-73562e494634c4105234c49d78a34b6162b9f4fc.tar.gz
gentoo-73562e494634c4105234c49d78a34b6162b9f4fc.tar.bz2
gentoo-73562e494634c4105234c49d78a34b6162b9f4fc.zip
dev-python/cursive: 0.1.2 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/cursive')
-rw-r--r--dev-python/cursive/Manifest1
-rw-r--r--dev-python/cursive/cursive-0.1.2.ebuild33
-rw-r--r--dev-python/cursive/metadata.xml2
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/cursive/Manifest b/dev-python/cursive/Manifest
index 2be80ef48970..33c92c15fd3d 100644
--- a/dev-python/cursive/Manifest
+++ b/dev-python/cursive/Manifest
@@ -1 +1,2 @@
DIST cursive-0.1.1.tar.gz 18522 SHA256 751745b868f6450d928749c9d08b0040bd13f82bcf7c4ed414a57da66b2bc104 SHA512 3a6ae804c010ae2b596eac8fbc3c9be6d7994ea8984513617f1eaa7c77c8335ce2c36419d8e6acadb305210d96d51ead8470a79e8425f2c00ef0dc9ead59929b WHIRLPOOL 8c5705780deb037fb61e9a511fecda55673fa069cda0d4e605c7387266a18bc6eefb3992910f44464268a86f6fd26580f381e8e96847eb04f1d51fef9deaacfe
+DIST cursive-0.1.2.tar.gz 18620 SHA256 6d36beccc3fcfb0ad0a0f38e5474775b91676116736a1cd158318f2a40a81103 SHA512 e8957df9de252435a534bef3b84c6b96de369036515e74614433f4d270aa8cb0bc4f467591a839ddb3b5f76ab7f302b18d6af5f79c7554f027a3cfb4e0571fba WHIRLPOOL 596cc56836bfc76c2f95100faa82d386f600e0862ca63ce325eac467df80318ae7724d6674c92fa08a9cc790a4191c5e36546c4163e00cb9592f5d8cf5f2f5f4
diff --git a/dev-python/cursive/cursive-0.1.2.ebuild b/dev-python/cursive/cursive-0.1.2.ebuild
new file mode 100644
index 000000000000..0b9d87d49026
--- /dev/null
+++ b/dev-python/cursive/cursive-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/cursive/metadata.xml b/dev-python/cursive/metadata.xml
index 1d683b2f3460..c1128eadb030 100644
--- a/dev-python/cursive/metadata.xml
+++ b/dev-python/cursive/metadata.xml
@@ -10,7 +10,7 @@
<name>Openstack</name>
</maintainer>
<longdescription lang="en">
- Cursive implements OpenStack-specific validation of digital signatures.
+ Cursive implements OpenStack-specific validation of digital signatures.
</longdescription>
<upstream>
<remote-id type="pypi">cursive</remote-id>