summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-28 08:28:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-28 09:08:53 +0200
commit55743c9496cd12a1bb18f532ffe2bf99895c2860 (patch)
treef1c30a7356d23a70c63e03f743e9aa1acf549ce8 /dev-python/cssselect
parentdev-python/plotly: Remove old (diff)
downloadgentoo-55743c9496cd12a1bb18f532ffe2bf99895c2860.tar.gz
gentoo-55743c9496cd12a1bb18f532ffe2bf99895c2860.tar.bz2
gentoo-55743c9496cd12a1bb18f532ffe2bf99895c2860.zip
dev-python/cssselect: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cssselect')
-rw-r--r--dev-python/cssselect/Manifest1
-rw-r--r--dev-python/cssselect/cssselect-1.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/cssselect/Manifest b/dev-python/cssselect/Manifest
index aac0457f118f..78e7c89735f2 100644
--- a/dev-python/cssselect/Manifest
+++ b/dev-python/cssselect/Manifest
@@ -1 +1,2 @@
DIST cssselect-1.1.0.tar.gz 35516 BLAKE2B b4480ad4335ba15ae8a2ae758ff942865a5b61de68b3b00fb59d517b1dacfce1cd817280e4aac562dbf829f90601a56220f01d99aecbc502420b9102e50c46ca SHA512 b33bca6a026f4de37b75606fd238dbd170b57d06288fbff3ea97ce79685a99af275fb8522b04ea9d6693aba5a18541d70b657191fdad881be79718bcf2e7655c
+DIST cssselect-1.2.0.gh.tar.gz 40878 BLAKE2B 951b33ee65d73ba14594f8475c764ae132a44ed7a6bb6effbcf445aa956e5390595b1f1139747331bfdd42d56ecb6d4aba3c88ceb2a103c456423543c41af95e SHA512 439f83e37c381f962abcfca0b83050372cbad44179e876591d8504abc2da1d4fe80891c8c8e1763341cf152525259565dc5e80038fa7c14e8c69f22a11f83d94
diff --git a/dev-python/cssselect/cssselect-1.2.0.ebuild b/dev-python/cssselect/cssselect-1.2.0.ebuild
new file mode 100644
index 000000000000..4b5575cd375d
--- /dev/null
+++ b/dev-python/cssselect/cssselect-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse CSS3 Selectors and translate them to XPath 1.0"
+HOMEPAGE="
+ https://cssselect.readthedocs.io/en/latest/
+ https://github.com/scrapy/cssselect/
+ https://pypi.org/project/cssselect/
+"
+SRC_URI="
+ https://github.com/scrapy/cssselect/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest