summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-05-08 15:16:46 +0500
committerMichał Górny <mgorny@gentoo.org>2017-05-08 19:02:12 +0200
commitaa4c797c83e1b379251290ebdbdffd9cda9ccad5 (patch)
tree168e73eb0e5f34d46160df6b34ad11153abffa89 /dev-python/construct
parentmedia-sound/gmusicbrowser: sync release & git (9999) ebuilds (diff)
downloadgentoo-aa4c797c83e1b379251290ebdbdffd9cda9ccad5.tar.gz
gentoo-aa4c797c83e1b379251290ebdbdffd9cda9ccad5.tar.bz2
gentoo-aa4c797c83e1b379251290ebdbdffd9cda9ccad5.zip
dev-python/construct: Version bump to 2.8.12
Next stable release branch. Added tests. Closes: https://github.com/gentoo/gentoo/pull/3899 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.8.12.ebuild34
-rw-r--r--dev-python/construct/metadata.xml1
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index f360b2df75ed..67412f113a13 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1 +1,2 @@
DIST construct-2.5.2.tar.gz 58373 SHA256 665b6271eeadf15219c726b180c8d7a641d026784d72ca3dad90a20aae009020 SHA512 dbfa28f58821811fa28ef170818d74212e76389a017c4073acd24025ace292285828506cb44387ff07c1c05ae70766a3a0679baea25deb3b0dcc31c85b24340b WHIRLPOOL ebe5ac0a09e317a2d8c123f24c110b3ea303c179710da6112c8f376bbf1d526c4c29ebf7f60c12f8873f74ec4ebabf010b4e537173fe28f166da6f49b79635cc
+DIST construct-2.8.12.tar.gz 720277 SHA256 67ee2c69a11bdadc0705c7e0de0ff16ef74b730932537e22ac1f64f479240ffa SHA512 4d0f59623a62eeab3c10e95b4e8153a1593219bcbcbbe5f87e75ba0a010b62021a9502faf715623faa78b4e397f1a74b41e9bffd1ede92dbebf87b0d4a59b66b WHIRLPOOL a73a2ad27c32e0ec59eb2b04fb45eb9f16e93460f722c3d19007840e141dd846695659adff3f6d50581fbf4ecaa37b982317722fda847bf3eb298432146ec19d
diff --git a/dev-python/construct/construct-2.8.12.ebuild b/dev-python/construct/construct-2.8.12.ebuild
new file mode 100644
index 000000000000..ccaed037621f
--- /dev/null
+++ b/dev-python/construct/construct-2.8.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.python.org/pypi/construct"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ ewarn "Version 2.8.x has significant API and implementation changes from"
+ ewarn "previous 2.5.x releases. Please read the documentation at"
+ ewarn "http://construct.readthedocs.io/ for more info."
+}
diff --git a/dev-python/construct/metadata.xml b/dev-python/construct/metadata.xml
index 0dbbbff97b7e..db2f49e944c6 100644
--- a/dev-python/construct/metadata.xml
+++ b/dev-python/construct/metadata.xml
@@ -6,6 +6,7 @@
<name>Python</name>
</maintainer>
<upstream>
+ <remote-id type="github">construct/construct</remote-id>
<remote-id type="pypi">construct</remote-id>
</upstream>
</pkgmetadata>