summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-04 15:52:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-04 16:22:44 +0200
commit94925f73b59b9225622ed0c44622e2b2105aaf04 (patch)
tree4e7bd7ccce61e7c70d23ee41d48cba0e04dfff95 /dev-python/construct
parentdev-python/decorator: Bump to 5.0.5 (diff)
downloadgentoo-94925f73b59b9225622ed0c44622e2b2105aaf04.tar.gz
gentoo-94925f73b59b9225622ed0c44622e2b2105aaf04.tar.bz2
gentoo-94925f73b59b9225622ed0c44622e2b2105aaf04.zip
dev-python/construct: Bump to 2.10.66
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.66.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 6402ea0661b3..0cb6e342af26 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1,3 +1,4 @@
DIST construct-2.10.61.tar.gz 1185872 BLAKE2B 03eb83b707f607f65f13f6430815af3f91f728e133cc1a889f4ff37e34b249cff8f8b13ffb764fbffbba2bec699ce94173e3b80498c42f8fc7628a125b659188 SHA512 dd25f9646d55c4914fbb506b795dced01a5a2d58a9d8378ceaa4d5ba666c9547e96f7a658e8d521ef9a3f53065e89b90e0c8560bc2eb4095b9ff8077b840eec4
DIST construct-2.10.63.tar.gz 1186101 BLAKE2B c0996f1228f36679d58ca931b27abb0b62da989d1554763295cf56086c9e288b3a02a4de23cca78a726a84c6483581662b01c8eb516d59a165b38eca8cc150f7 SHA512 6d3202f4c98f9c14edaf0c3ea90875eb43c9e3ca454f54a2fe3c6d7810957781a0fe95c60cb6b28445ab80a9ad3ae52c4a397cf9b3531f42d1cb443564427a9c
DIST construct-2.10.64.tar.gz 1186820 BLAKE2B f3b238060d9db1511effdb4c4374d5e8df0a90d9ea015793766ba29718c0ea2c43a2e8d892076b6b148574bb35e0813299b1c009149f9057d46c0a7f0cef63ec SHA512 00eee1d330457dffe854d5a709c21a8f6e71034695ea9aaffb886c198f2cf56b142f0d5d9edbeee480b77a13f8f8c1faaf6b84eed4161882d77623935502460a
+DIST construct-2.10.66.tar.gz 1189924 BLAKE2B 1c0eb91bd8391a8677a2af7b24ce471d961ba97c0e297969c956a4a6f7e8a35ac539882dfb15da94455e8c9c24e9411d11e981ee180bf54179e11735409718fa SHA512 66e23d1c92dd5472098ca1f971d781a0846a6bcfd797d9d71781f1ff7288f1e7d21b68176e8353409fc355979b1636f4f5a0ef86547d96860636296d19d340c2
diff --git a/dev-python/construct/construct-2.10.66.ebuild b/dev-python/construct/construct-2.10.66.ebuild
new file mode 100644
index 000000000000..79ca0ff13275
--- /dev/null
+++ b/dev-python/construct/construct-2.10.66.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --ignore tests/test_benchmarks.py
+}
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}