summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-30 14:23:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-30 14:34:53 +0100
commit1c8491541f27c1d1742abc324952ccf69f91fbde (patch)
treebe55e0cc6cefbf24e0403db84219fb9d0557a954 /dev-python/construct
parentdev-python/pgspecial: Deselect broken test (diff)
downloadgentoo-1c8491541f27c1d1742abc324952ccf69f91fbde.tar.gz
gentoo-1c8491541f27c1d1742abc324952ccf69f91fbde.tar.bz2
gentoo-1c8491541f27c1d1742abc324952ccf69f91fbde.zip
dev-python/construct: Bump to 2.10.70
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.70.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index c3e8d4165e55..766a648cad84 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1 +1,2 @@
DIST construct-2.10.69.gh.tar.gz 1195652 BLAKE2B 003353d4be4992ecb9e32b845a35a4850f451e3ead40af2c1b9d3380c27b58088e75e20ff76c733e573594e1ae08406c188868907c0f335c13e23cb01bf7481f SHA512 c94a1b3a62c9bf4aed30eb262d4439452f98fe909e399d79ece8da4aa707f95c754d540672c2cc9c307425914e43384b5455eb7970ab5d7830af1c0b06313f9e
+DIST construct-2.10.70.gh.tar.gz 1196623 BLAKE2B 98206e9fbf65c208172cfc4ac983c636fe022a51891a9d8f784c87656d2143f97fd7ec108cc24ca857a589479fe5ca17beb8db245c300d5bb90fdfd2859e5801 SHA512 1c4fe99d36266bf68f4876fdaea5b7cbbb2ea202b73cf4b54f92b443cd753200aec52a15ff97001c9e040b3c16ecc8dd444bbac26f7860100087e430beab1f81
diff --git a/dev-python/construct/construct-2.10.70.ebuild b/dev-python/construct/construct-2.10.70.ebuild
new file mode 100644
index 000000000000..53bffe5dd8d1
--- /dev/null
+++ b/dev-python/construct/construct-2.10.70.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="
+ https://construct.readthedocs.io/en/latest/
+ https://github.com/construct/construct/
+ https://pypi.org/project/construct/
+"
+SRC_URI="
+ https://github.com/construct/construct/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)