summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 07:06:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 07:35:48 +0200
commita4421c25b6f04714f208583120995cb3bb43f21e (patch)
tree40b355d9c1f4396d83ac2a6845cf51bfbc29d2ef /dev-python/cons
parentdev-python/aws-sam-translator: Bump to 1.70.0 (diff)
downloadgentoo-a4421c25b6f04714f208583120995cb3bb43f21e.tar.gz
gentoo-a4421c25b6f04714f208583120995cb3bb43f21e.tar.bz2
gentoo-a4421c25b6f04714f208583120995cb3bb43f21e.zip
dev-python/cons: Bump to 0.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cons')
-rw-r--r--dev-python/cons/Manifest1
-rw-r--r--dev-python/cons/cons-0.4.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/cons/Manifest b/dev-python/cons/Manifest
index 939df9dd30a8..9bc0d1539881 100644
--- a/dev-python/cons/Manifest
+++ b/dev-python/cons/Manifest
@@ -1 +1,2 @@
DIST cons-0.4.5.gh.tar.gz 40318 BLAKE2B c01f195c4f29ffe42e08fba6b57806b96263f7ebbc1cc859b8d146cd94e257829506502f2bc81f5665f4caf3bb8725ec556b70b951ede2b8117ba50fdb4388e5 SHA512 fea3af6b7198760f36194793a32a87f17729877f75baca6fd9627c32c4602e640cf667bb106624e9d756aece57053974e90e32329de484619a14b3500bea26e7
+DIST cons-0.4.6.gh.tar.gz 40414 BLAKE2B 5d234ed77d44f0b892c3cc8fc4816a4cc1ca5cca36501adca8cbc84a48dff320c3ea45555aaa2203d1ed5072e74404e62184f000db393c155b008943990b7df3 SHA512 195a2e23a6ee37aba1cc34c0f26a2b55f86948c4a2eb5dab50b9b917bdee97bbb53562830c75184c8483260ba9bc9352d1430f99937aa29156cbf3ce2fb0254b
diff --git a/dev-python/cons/cons-0.4.6.ebuild b/dev-python/cons/cons-0.4.6.ebuild
new file mode 100644
index 000000000000..765c7e56f5b2
--- /dev/null
+++ b/dev-python/cons/cons-0.4.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of Lisp/Scheme-like cons in Python"
+HOMEPAGE="
+ https://pypi.org/project/cons/
+ https://github.com/pythological/python-cons/
+"
+SRC_URI="
+ https://github.com/pythological/python-cons/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest