summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2023-12-15 23:30:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-17 11:36:31 +0100
commit989f426590a795e20ebe7795ebefcc37544dbc48 (patch)
tree1972235c7ae213bfc361d129a8e0c093de7ef44d /dev-python/colorful
parentdev-ruby/acme-client: drop 2.0.9 (diff)
downloadgentoo-989f426590a795e20ebe7795ebefcc37544dbc48.tar.gz
gentoo-989f426590a795e20ebe7795ebefcc37544dbc48.tar.bz2
gentoo-989f426590a795e20ebe7795ebefcc37544dbc48.zip
dev-python/colorful: new package, add 0.5.5
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34300 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/colorful')
-rw-r--r--dev-python/colorful/Manifest1
-rw-r--r--dev-python/colorful/colorful-0.5.5.ebuild41
-rw-r--r--dev-python/colorful/metadata.xml25
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/colorful/Manifest b/dev-python/colorful/Manifest
new file mode 100644
index 000000000000..6acf1fa6b07b
--- /dev/null
+++ b/dev-python/colorful/Manifest
@@ -0,0 +1 @@
+DIST colorful-0.5.5.gh.tar.gz 366498 BLAKE2B a7ab5dfb7ddfbf6682b75d2ed35f3f4cb7c3826918742316d877a17cb58e639b5fa86d7906be4879e89a5a0e78a16ede7535ade3f9f890c67bfcf42a0d1c9d9c SHA512 dc5e372261bd308a82bd0446a885b4c63a5a5781540731407f1a364d2c5397fe950f96fef3be8ffeab80cf02010be9551ba5b8550930e3fed5173cdc28a69306
diff --git a/dev-python/colorful/colorful-0.5.5.ebuild b/dev-python/colorful/colorful-0.5.5.ebuild
new file mode 100644
index 000000000000..35e9e56ee19c
--- /dev/null
+++ b/dev-python/colorful/colorful-0.5.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal string styling done right, in Python"
+HOMEPAGE="
+ https://pypi.org/project/colorful/
+ https://github.com/timofurrer/colorful/
+"
+SRC_URI="
+ https://github.com/timofurrer/colorful/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Fix QA_issue python package discovery
+ # https://github.com/timofurrer/colorful/pull/53
+ sed -i \
+ -e "s/find_packages/find_namespace_packages/" \
+ -e "s/(exclude=\['\*tests\*'\])/(exclude=\['\*tests\*'\, '\*examples\*'\])/" \
+ setup.py || die "Error fixing setup.py for >=PEP420"
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -s
+}
diff --git a/dev-python/colorful/metadata.xml b/dev-python/colorful/metadata.xml
new file mode 100644
index 000000000000..be5dd72ee646
--- /dev/null
+++ b/dev-python/colorful/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>foti.giuseppe@gmail.com</email>
+ <name>Giuseppe Foti</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Package used for styling terminal strings in Python scripts.
+ This package is used as a dependency in net-analyzer/pontos.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">timofurrer/colorful</remote-id>
+ <remote-id type="pypi">colorful</remote-id>
+ </upstream>
+</pkgmetadata>