summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-06-30 09:23:38 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-06-30 09:29:46 +0200
commitf525c925230ebd337597089b74abc888fc2b3729 (patch)
treef61d7a96924897d7434039619ed4cfe209237ebf /dev-python/coloredlogs
parentdev-python/capturer: fix variable order (diff)
downloadgentoo-f525c925230ebd337597089b74abc888fc2b3729.tar.gz
gentoo-f525c925230ebd337597089b74abc888fc2b3729.tar.bz2
gentoo-f525c925230ebd337597089b74abc888fc2b3729.zip
dev-python/coloredlogs: enable py3.13
It was necessary to apply patch [1] in order to make py3.13 work. [1] https://github.com/xolox/python-coloredlogs/pull/120 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-python/coloredlogs')
-rw-r--r--dev-python/coloredlogs/coloredlogs-15.0.1-r2.ebuild47
-rw-r--r--dev-python/coloredlogs/files/coloredlogs-15.0.1-py3.13.patch43
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/coloredlogs-15.0.1-r2.ebuild b/dev-python/coloredlogs/coloredlogs-15.0.1-r2.ebuild
new file mode 100644
index 000000000000..8f538d93ebff
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-15.0.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/humanfriendly-9.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-14.0-fix-install-prefix.patch"
+ "${FILESDIR}/${PN}-15.0.1-py3.13.patch"
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test_auto_install fails because the pth file isn't being loaded
+ coloredlogs/tests.py::ColoredLogsTestCase::test_auto_install
+)
+
+python_test() {
+ epytest coloredlogs/tests.py
+}
diff --git a/dev-python/coloredlogs/files/coloredlogs-15.0.1-py3.13.patch b/dev-python/coloredlogs/files/coloredlogs-15.0.1-py3.13.patch
new file mode 100644
index 000000000000..649683b4944e
--- /dev/null
+++ b/dev-python/coloredlogs/files/coloredlogs-15.0.1-py3.13.patch
@@ -0,0 +1,43 @@
+From 9d4f4020897fcf48d381de8e099dc29b53fc9531 Mon Sep 17 00:00:00 2001
+From: "Benjamin A. Beasley" <code@musicinmybrain.net>
+Date: Wed, 12 Jun 2024 14:00:28 -0400
+Subject: [PATCH] Replace pipes.quote with shlex.quote on Python 3
+
+The shlex.quote() API is available from Python 3.3 on; pipes.quote() was
+never documented, and is removed in Python 3.13.
+
+Fixes #119.
+
+Upstream-PR: https://github.com/xolox/python-coloredlogs/pull/120
+Upstream-Issue: https://github.com/xolox/python-coloredlogs/issues/119
+
+diff --git a/coloredlogs/converter/__init__.py b/coloredlogs/converter/__init__.py
+index a424469..96817a0 100644
+--- a/coloredlogs/converter/__init__.py
++++ b/coloredlogs/converter/__init__.py
+@@ -9,11 +9,15 @@
+ # Standard library modules.
+ import codecs
+ import os
+-import pipes
+ import re
+ import subprocess
+ import tempfile
+
++try:
++ from shlex import quote # Python 3
++except ImportError:
++ from pipes import quote # Python 2 (removed in 3.13)
++
+ # External dependencies.
+ from humanfriendly.terminal import (
+ ANSI_CSI,
+@@ -75,7 +79,7 @@ def capture(command, encoding='UTF-8'):
+ #
+ # [1] http://man7.org/linux/man-pages/man1/script.1.html
+ # [2] https://developer.apple.com/legacy/library/documentation/Darwin/Reference/ManPages/man1/script.1.html
+- command_line = ['script', '-qc', ' '.join(map(pipes.quote, command)), '/dev/null']
++ command_line = ['script', '-qc', ' '.join(map(quote, command)), '/dev/null']
+ script = subprocess.Popen(command_line, stdout=subprocess.PIPE, stderr=dev_null)
+ stdout, stderr = script.communicate()
+ if script.returncode == 0: