summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 10:16:58 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-08 10:18:13 +0100
commita2f7f2523b9fe739bb67df101c6b01c856e81cbb (patch)
tree0d6e41e85196ff3ae59868c811f198489ee8aada /dev-python/coloredlogs
parentdev-python/capturer: update EAPI 7 -> 8, pep517, enable py3.11 (diff)
downloadgentoo-a2f7f2523b9fe739bb67df101c6b01c856e81cbb.tar.gz
gentoo-a2f7f2523b9fe739bb67df101c6b01c856e81cbb.tar.bz2
gentoo-a2f7f2523b9fe739bb67df101c6b01c856e81cbb.zip
dev-python/coloredlogs: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/coloredlogs')
-rw-r--r--dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild b/dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild
new file mode 100644
index 000000000000..6512b8283079
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/humanfriendly-9.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/coloredlogs-14.0-fix-install-prefix.patch" )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test_auto_install fails because the pth file isn't being loaded
+ coloredlogs/tests.py::ColoredLogsTestCase::test_auto_install
+)
+
+python_test() {
+ epytest coloredlogs/tests.py
+}