summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 04:24:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 04:24:43 +0200
commitfca16e7ea7d29216965d66612a3e475988087f8f (patch)
treecfe2d9965f04ed3c76394c0aad6a6151fa2b1476 /dev-python/cfn-lint
parentdev-python/unearth: Bump to 0.16.1 (diff)
downloadgentoo-fca16e7ea7d29216965d66612a3e475988087f8f.tar.gz
gentoo-fca16e7ea7d29216965d66612a3e475988087f8f.tar.bz2
gentoo-fca16e7ea7d29216965d66612a3e475988087f8f.zip
dev-python/cfn-lint: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.6.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index c0d0ac0c408e..143cb980cb64 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -4,3 +4,4 @@ DIST cfn_lint-1.3.7.tar.gz 2469769 BLAKE2B aa059688cee5dfc35ea76a0d771e3c3d37078
DIST cfn_lint-1.4.2.tar.gz 2485843 BLAKE2B c2e64721b537ab38cad3c3f6d40c509741fb03f61202d7dace4023f4b5b3a7840b7deb88892d9d282d223756a1e3908680ed166cdf216b0c76abdc29d0749967 SHA512 c9761e253ba77198264eabdd9c4e6a290bb9010533628958853c8d5a0f5f7317338f271588b5cef2ac1667f6ed5e1a6e43a3192aa9ff7202b0ca6db061284818
DIST cfn_lint-1.5.2.tar.gz 2353616 BLAKE2B 2f7231c1c0b51668c1994558a6bfac24c250087736d1edab8dc3d266a5503c6298336749fb9e49f8b4953df6dcbe53a028cefde7c122fe942d0974c1f193413c SHA512 36fee3f67566c831224ce00efe2851df6df8f159ad6d843636948de9babfb56bbaa2789cfd6d8373493b482471d9caa046925f4a4d6bc61c5cae62ec8820a9b3
DIST cfn_lint-1.5.3.tar.gz 2354279 BLAKE2B b8c836db35453efbb27fd050a4cb3090ca99fb050256c4e0b8cd5b634320d677f2ed325894a700127891b614ab70cd436e7af06759f9dbcf58ad45f4b50ee779 SHA512 38ce749f21e6118f129d98d21ecc01bc4f828efce8af9f597f624eff9a062dbceb8c670cfbaa0cf581c14d187094ffe90ada4293679c1e0f77cb3baff3308b26
+DIST cfn_lint-1.6.0.tar.gz 2365490 BLAKE2B 642ef47068f6684c721c65a2a71701ece4a16534494493730b7e8e898f54df471250402103480adcf0d6db0cf4cbeeb2c2120fd13e4d27ad9c4033defeba221b SHA512 d563e86745a7f3926011765c08c2b64fa5cae2c9772ecb81cb3807e6ba328f9ae868dc13fe66297e49eb3b71323a76b6f7537929a731e44a79afacfa7fb9c127
diff --git a/dev-python/cfn-lint/cfn-lint-1.6.0.ebuild b/dev-python/cfn-lint/cfn-lint-1.6.0.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}