summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-27 04:25:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-27 04:53:42 +0200
commitd8aa2623dfb0003e8fd259d69893ab55530123bf (patch)
tree4e93834b35e7df97fdbbbca30216e332c00b81cc /dev-python/cfn-lint
parentdev-python/sqlglot: Remove old (diff)
downloadgentoo-d8aa2623dfb0003e8fd259d69893ab55530123bf.tar.gz
gentoo-d8aa2623dfb0003e8fd259d69893ab55530123bf.tar.bz2
gentoo-d8aa2623dfb0003e8fd259d69893ab55530123bf.zip
dev-python/cfn-lint: Bump to 1.3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.3.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 840d5e742188..51276b00a9be 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn_lint-0.87.7.tar.gz 4077539 BLAKE2B d7382b8112332821988854f719a2965749b5
DIST cfn_lint-0.87.8.tar.gz 4136317 BLAKE2B eb0c30ff83ea9eca80b0a5e2a364e9d013bae2edc245fff61e1a77ff969a23314b2f918a061f03dff6aded543563f1c318ffb389eb4a8cf1da4a142892b0f31b SHA512 044e9f5e88b4264c5782d25f4216e328cb4cc6b09441790fc150c0162393505f2f874cf8992b870772091970557aa6fa5d1991e35c61253c33f75d7f17070ad3
DIST cfn_lint-1.3.3.tar.gz 2474929 BLAKE2B d5c8685e48739b178a1ab222b90a31626fffc9dfa91e9fbac6554d33d559a675ef50a2670c00a750aeac057777d29ac6a95526829862794ac289d30d53e268ec SHA512 726e96d4b5fa7e3446382cd8050dc99dce1cb848f7a11f5d1795c5a1a408b1d9e9148f7e3aea7887ebb361b1fd597c434ca0fbbf6a31631d8ac021aaf522427f
DIST cfn_lint-1.3.4.tar.gz 2456919 BLAKE2B 31df1d53b01831310abd84ba83f262307c12fba20af6e6fb372a95b0d0ae9bffb690ded617a53cb0efc929e41bff9a51c6caadf246446eeaaa0e505a3d546eea SHA512 436e22c582a179cd667e5a8ae165f4cd3c4faf4ba78ec278adfa70b4bfea105f6a5c922326e3002ff0eed4365d87b1d7f1ee12bd7a55e605b7c59c09a492433d
+DIST cfn_lint-1.3.7.tar.gz 2469769 BLAKE2B aa059688cee5dfc35ea76a0d771e3c3d370780d6bacef2f524f60a408b572eb92a23367141cbe195afff0e0599102b4fc05354e2bd9d712f936db32f47a4bf91 SHA512 77dbc087c91d75946838567dd95d4fbd32131e07020d8076748154ae1b2cbeea1f348e650534279fa573732dc22691e65e0e542f539156b0af59ff5422396ffc
diff --git a/dev-python/cfn-lint/cfn-lint-1.3.7.ebuild b/dev-python/cfn-lint/cfn-lint-1.3.7.ebuild
new file mode 100644
index 000000000000..fef826927bf5
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.3.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}