summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 06:49:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 06:49:21 +0200
commitcaeabc6336b07252b40629121d5380ad40e189b2 (patch)
treeaf24d2e443bc69f13af9ad9849ab38d1cbe23c26 /dev-python/cfn-lint
parentdev-python/nbxmpp: Bump to 5.0.0 (diff)
downloadgentoo-caeabc6336b07252b40629121d5380ad40e189b2.tar.gz
gentoo-caeabc6336b07252b40629121d5380ad40e189b2.tar.bz2
gentoo-caeabc6336b07252b40629121d5380ad40e189b2.zip
dev-python/cfn-lint: Bump to 0.87.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.87.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 73f204b49a38..fcacd7902d13 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn_lint-0.87.1.tar.gz 3997592 BLAKE2B 058de8badb0b37bda16e5239a2d9aa372780
DIST cfn_lint-0.87.2.tar.gz 3963369 BLAKE2B e1238db45fa2856ed1becdbaeccd2bd7aab3c0c3f54e3bd13cdad27d20c0c9e0c85a232121f63b152554f95066cf24119b9e2c02d0402d673ed5d7eefc8565ed SHA512 b0503138d7ca939003b472ce0e35ae0f0c3aa9550cc889e28a709856051d059c619c2ac5d47735ce0702cb975949d6ea64aff6c2b5168738ccf8afbcf950801d
DIST cfn_lint-0.87.3.tar.gz 3963065 BLAKE2B 400532698248204fe2bbf9f29fb374d178cd4a8b168dcb681b284da0d5d7be17cd28292b8f37a7c600936b96a56e90d925e5e0d88f062f5c8a7821f0ffe43528 SHA512 b23ed7259907da993469b4b2a6cfb6a5b8f1bc9186d65e8392ccf628b8b37fe7a0bde6d5d57ca6924d738770367e67245f13abce4777fa88945316569eb59b4b
DIST cfn_lint-0.87.4.tar.gz 3971540 BLAKE2B 75fda8093cb10dd289966fa3732f9e1572d3bdda4aad6431d3982eecf8c09e98d404d49aa607ae3928a8c87b93608d06c1ad83f75de6edbfbd35362827f1b699 SHA512 75298ad1577297d885af7afb7c2828215d4261069346aa1231fbfbf5cb6b4bf32cdeabdbbfeae7a4ddd3cca162ab977075abf8588e5a241ed952f3ff3f5d85f6
+DIST cfn_lint-0.87.5.tar.gz 4059125 BLAKE2B 93d1b6ad445628360f62d1d4ceab75af85c1ed8ae9b5ac667f70346e5ddb6e75cac57544f5fb4f1f44d30503041c2259a4cedcd4be343eb7408b6d82a9e2fe9a SHA512 3a1fc8514a9490544190e6f8b9d1333676683ebdafbe040660558f9c2cd3675494ac44979019f1fc57857cb692ee32000e60218a9abb959e686949ff032e6eb9
diff --git a/dev-python/cfn-lint/cfn-lint-0.87.5.ebuild b/dev-python/cfn-lint/cfn-lint-0.87.5.ebuild
new file mode 100644
index 000000000000..1965af60837c
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.87.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}