summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-13 07:00:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-13 07:55:02 +0100
commit7b38bd8057b2ddc0174a73c6ba9c22420edf699c (patch)
treead4735b62994cefcc9d49206c798e0581e4f4246 /dev-python/cfn-lint
parentapp-admin/awscli: Bump to 1.36.0 (diff)
downloadgentoo-7b38bd8057b2ddc0174a73c6ba9c22420edf699c.tar.gz
gentoo-7b38bd8057b2ddc0174a73c6ba9c22420edf699c.tar.bz2
gentoo-7b38bd8057b2ddc0174a73c6ba9c22420edf699c.zip
dev-python/cfn-lint: Bump to 1.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.19.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 4d5760ed3403..33d11c788926 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-1.17.2.tar.gz 2526962 BLAKE2B 76feefa1bcce6a0957ce028d6041ac49b475cf25bd843e7de30b1d05d797e55d4189d9deba087f569f94f2f8fc40b11c3ecddcab1593432abf0da1bd26db6da9 SHA512 79fa133244cfe1239648209da9e8bbb2e50435bc5c18b6f998c90eb09536a760dfae62507123c22295098bf0866b1ef0ed05853debb00e651b75651921401530
DIST cfn_lint-1.18.3.tar.gz 2768521 BLAKE2B 277d52b6005e175bf87094dc6a0c71e660217db2665a03f1408ed03d67c2b72aefd0d2ed377869932aabeb351449eb6f7e05db3d8abebe94eed18b60d4c9c283 SHA512 27803f683f8f0440b71925a511fd9cd81c8a81c35a04b267a6f67833d40e2d1dca94f9c81bad507ede02c049ef5143372d5e9aa148ea5242b946d1cd3ac55a77
DIST cfn_lint-1.18.4.tar.gz 2788919 BLAKE2B c9815d61450d6afa6f054a305b90ceb14a2dd72206834fb64c8e51017cbcf02843dc83e909d1db0dfb183d7f059909a9b794e886745bbe48cac42dcf2c109150 SHA512 fc8ed928fa83d262000c141805734c788559f2ed7ad7b1b989771069cd8972c04dba67a8c4823cceb35ad70db19e28c5f36093cf42f86b232f35eeba8585c89b
+DIST cfn_lint-1.19.0.tar.gz 3074770 BLAKE2B 955ad65135242dc0cc64de3495db59da204ab102817e1da2d2d654c0df0a5d5834b8e2aab91fe15dd08daecef00d46297dc76129ac4ed670fc291e7e69fd6908 SHA512 84115aa5131219e01d038b4a7dd12c1ea2ffce8fbc7e4af22bd8e031f980d342db20ceb4c9f27e96602df19cca10eba84dfd066742606e156357bdac97eefb19
diff --git a/dev-python/cfn-lint/cfn-lint-1.19.0.ebuild b/dev-python/cfn-lint/cfn-lint-1.19.0.ebuild
new file mode 100644
index 000000000000..086f03ea08df
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.19.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.91.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}