summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 06:17:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 06:44:50 +0200
commit608ec02c3a0d38168da66bdea96abda398acb9cd (patch)
treee946c9d007631848fdc1d484599823afb3f836b2 /dev-python/cfn-lint
parentdev-python/hishel: Bump to 0.0.30 (diff)
downloadgentoo-608ec02c3a0d38168da66bdea96abda398acb9cd.tar.gz
gentoo-608ec02c3a0d38168da66bdea96abda398acb9cd.tar.bz2
gentoo-608ec02c3a0d38168da66bdea96abda398acb9cd.zip
dev-python/cfn-lint: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.6.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 143cb980cb64..74aab1c3b223 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -5,3 +5,4 @@ DIST cfn_lint-1.4.2.tar.gz 2485843 BLAKE2B c2e64721b537ab38cad3c3f6d40c509741fb0
DIST cfn_lint-1.5.2.tar.gz 2353616 BLAKE2B 2f7231c1c0b51668c1994558a6bfac24c250087736d1edab8dc3d266a5503c6298336749fb9e49f8b4953df6dcbe53a028cefde7c122fe942d0974c1f193413c SHA512 36fee3f67566c831224ce00efe2851df6df8f159ad6d843636948de9babfb56bbaa2789cfd6d8373493b482471d9caa046925f4a4d6bc61c5cae62ec8820a9b3
DIST cfn_lint-1.5.3.tar.gz 2354279 BLAKE2B b8c836db35453efbb27fd050a4cb3090ca99fb050256c4e0b8cd5b634320d677f2ed325894a700127891b614ab70cd436e7af06759f9dbcf58ad45f4b50ee779 SHA512 38ce749f21e6118f129d98d21ecc01bc4f828efce8af9f597f624eff9a062dbceb8c670cfbaa0cf581c14d187094ffe90ada4293679c1e0f77cb3baff3308b26
DIST cfn_lint-1.6.0.tar.gz 2365490 BLAKE2B 642ef47068f6684c721c65a2a71701ece4a16534494493730b7e8e898f54df471250402103480adcf0d6db0cf4cbeeb2c2120fd13e4d27ad9c4033defeba221b SHA512 d563e86745a7f3926011765c08c2b64fa5cae2c9772ecb81cb3807e6ba328f9ae868dc13fe66297e49eb3b71323a76b6f7537929a731e44a79afacfa7fb9c127
+DIST cfn_lint-1.6.1.tar.gz 2366313 BLAKE2B af7b3e8d5145f3368d4c7b2e86b0ffe441c1f6633de34024e8c10d8cd04625673a25e847c15f30a6778bee8196096ffca58241e3a6f21a750094a3b2845f5493 SHA512 f354fa40677f8b601dabfb12b8715f4eb49f8e8aec72d3b9eeb4a63fabe278c36629f404b193f557b193280d6ecd224f0f0a494f9dfc61a04ebb24d0fe953d67
diff --git a/dev-python/cfn-lint/cfn-lint-1.6.1.ebuild b/dev-python/cfn-lint/cfn-lint-1.6.1.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.6.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}