summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-20 06:58:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-20 07:13:28 +0100
commit83ea7fa0a9f5676fe3f89e786d1d175a873c8a2b (patch)
treeead23e24a1bc4c916e9c4e4c4dca259e8617483b /dev-python/cbor2
parentdev-python/sqlglot: Bump to 21.1.2 (diff)
downloadgentoo-83ea7fa0a9f5676fe3f89e786d1d175a873c8a2b.tar.gz
gentoo-83ea7fa0a9f5676fe3f89e786d1d175a873c8a2b.tar.bz2
gentoo-83ea7fa0a9f5676fe3f89e786d1d175a873c8a2b.zip
dev-python/cbor2: Bump to 5.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cbor2')
-rw-r--r--dev-python/cbor2/Manifest1
-rw-r--r--dev-python/cbor2/cbor2-5.6.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/cbor2/Manifest b/dev-python/cbor2/Manifest
index 38c10ee95f47..7f4215f0f92e 100644
--- a/dev-python/cbor2/Manifest
+++ b/dev-python/cbor2/Manifest
@@ -1,2 +1,3 @@
DIST cbor2-5.5.1.tar.gz 94221 BLAKE2B 651d229c9a4e5fda2ae61302f8bd72a165f15e008333525a301f2fc94dc81259698f4ae9b8c1f3a0b5fadffadd4d55f2ba4bf1445938a10342997bca64ceba31 SHA512 7878b997ae5bdf44cb04b7cef8445a94f11c1722819ea85073bd56f99976cf2c1c1180e72d9ae9cd7dd7d06a6aa55dc1cb3f919a869098a9feede210f8355fb4
DIST cbor2-5.6.1.tar.gz 99268 BLAKE2B 95a310c6fea00f90ba512d836691ab8fb75ebb9f6b59ca0698b7f97d2c969d2f8809ed2717c48354812f309856a35873c96571194dd86c48a225696b27ec806f SHA512 9ddf2c3690780816ff50ff4ed371435ca45b597b706254c37c9f01d1f1a699892e2c945a72e69b5506a803c41692f399b58b4e32d9409a0197c677e537e656b2
+DIST cbor2-5.6.2.tar.gz 100016 BLAKE2B a0a71f40f39ba86c545e5f8462af74e17b6851d350f0c9831be2ac414216437021150d0d7ddb481d62454d5ff73b99ccda7ae0676fd6d53b7e3228616fa0042d SHA512 da98aaf17b17b50bdfc4dbecc1e88e70ed6e99f26e9eb4124de0e92ea2d63f827cee3da83c9aeba1af386cf5a7e95d76be30c79b0a8fde7d53ee8c203b2119b9
diff --git a/dev-python/cbor2/cbor2-5.6.2.ebuild b/dev-python/cbor2/cbor2-5.6.2.ebuild
new file mode 100644
index 000000000000..4d83e1c675b4
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.6.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="
+ https://github.com/agronholm/cbor2/
+ https://pypi.org/project/cbor2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ >=dev-python/setuptools-61[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e "s/--cov//" pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x CBOR2_BUILD_C_EXTENSION=1
+ # pypy3 not supported upstream
+ if [[ ${EPYTHON} == pypy3 ]] || ! use native-extensions; then
+ CBOR2_BUILD_C_EXTENSION=0
+ fi
+ distutils-r1_python_compile
+}