summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-15 09:43:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-23 11:53:01 +0200
commit71b22f70b6456f4424a562dfd4d0e7ba234f6101 (patch)
treec10e1438491572c2e17539dea599213b0d74cc21 /dev-python/capturer
parentsys-apps/less: amd64 stable wrt bug #706004 (diff)
downloadgentoo-71b22f70b6456f4424a562dfd4d0e7ba234f6101.tar.gz
gentoo-71b22f70b6456f4424a562dfd4d0e7ba234f6101.tar.bz2
gentoo-71b22f70b6456f4424a562dfd4d0e7ba234f6101.zip
dev-python/capturer: Version bump 2.4 and add py3_7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/capturer')
-rw-r--r--dev-python/capturer/Manifest1
-rw-r--r--dev-python/capturer/capturer-2.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/capturer/Manifest b/dev-python/capturer/Manifest
index 13938f64a364..e79a6cc3ddd8 100644
--- a/dev-python/capturer/Manifest
+++ b/dev-python/capturer/Manifest
@@ -1 +1,2 @@
DIST capturer-2.3.tar.gz 18380 BLAKE2B e51f7013715e1bcf83da6126804aa3c223fcfeb7c4f958038f123e19dcb807bb480d46ed17307ccc312b2d5873dc9f82ed90f7be7f01b7062ef81c11829c6698 SHA512 267c6238ab143894f3d74002334b99e3d1a59a3bf30f5ad04d6f1a81c9439b1369fe161859f86924280e3b9e47536e53a0a80045acda9ae471ded7d751e01470
+DIST capturer-2.4.tar.gz 16963 BLAKE2B 329e388059a033993cf2ac3744a8df273beea0239f3696d19aece57767b0b5cd3397fa095f860c4f00ef24e8cd6bf2e58aab4158a86cf8c0c09c89d2065de0da SHA512 d85614b0424ab8817df9475ac0d230d7151289a3353a3c043a7fa89dac0528265a4dee535cac9ad0a3c2fbb0cac18afa69cd0a405b1becab55f9a6be13df0c46
diff --git a/dev-python/capturer/capturer-2.4.ebuild b/dev-python/capturer/capturer-2.4.ebuild
new file mode 100644
index 000000000000..a9537b2a2226
--- /dev/null
+++ b/dev-python/capturer/capturer-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.io/en/latest/
+ https://pypi.org/project/capturer/
+ https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}