summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-15 06:41:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-15 07:12:59 +0100
commited6753aaabf511407efe0674a9646f0908c2b407 (patch)
tree42ced69916e8bd7a0bd9b4510d1672edf630b59f /dev-python/canonicaljson
parentdev-cpp/highway: forward ~ia64 (diff)
downloadgentoo-ed6753aaabf511407efe0674a9646f0908c2b407.tar.gz
gentoo-ed6753aaabf511407efe0674a9646f0908c2b407.tar.bz2
gentoo-ed6753aaabf511407efe0674a9646f0908c2b407.zip
dev-python/canonicaljson: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/canonicaljson')
-rw-r--r--dev-python/canonicaljson/Manifest1
-rw-r--r--dev-python/canonicaljson/canonicaljson-2.0.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/canonicaljson/Manifest b/dev-python/canonicaljson/Manifest
index e1d9539118e9..a5258eb4dff2 100644
--- a/dev-python/canonicaljson/Manifest
+++ b/dev-python/canonicaljson/Manifest
@@ -1,2 +1,3 @@
DIST canonicaljson-1.6.4.gh.tar.gz 10408 BLAKE2B 4d55bb90cd4bbd5e019ffd0d505651c99dc6b296e9c0a52582265438586890cd6b663116ba0b66807b7a665c54eea001e039ca86c2fef9175b72a318a11a79a7 SHA512 7be1300c17d51f917b1e81931f6d0dd681b1eef9b7f4e82ba3ae683609d74fd924eb3a832c8261611f556c190329748966bf15abe34bc1d22f2ecdf29372b560
DIST canonicaljson-1.6.5.gh.tar.gz 10457 BLAKE2B 14a56133e6b907ddd897f1d2f183c6ac0ab247b629253e74fd76bf7a41092dabe20de51d5a3ef7c5d6c67c78c76c2174ef430aaf73d744477bb12a8eb1b1e4b2 SHA512 dc4c18b8b2cf833038ca77a7c1c5cac6b9e09b0bc902fa58db095767c23a7e6b24257694931a4db0503934535ae965f5ceafd26d42b9a6c9ae19821522b2d070
+DIST canonicaljson-2.0.0.tar.gz 10716 BLAKE2B e310e9e8e0437f0e5cc69d2e258887582f8ff010a242102a331b5d09686d0785bec35b8c1fd44ed18f4ad381af1710bc5edf186602106ab0196f33f48474a909 SHA512 aa9bed50f8d0c7c32451ec5f701c8a8b7d1139eb41797842eea1a86e7d86a52ddec6b1e0254469aa3c92ed1fc462bec647580d60d96c38be7d8bd8ee641b51b7
diff --git a/dev-python/canonicaljson/canonicaljson-2.0.0.ebuild b/dev-python/canonicaljson/canonicaljson-2.0.0.ebuild
new file mode 100644
index 000000000000..60cf4491e048
--- /dev/null
+++ b/dev-python/canonicaljson/canonicaljson-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical JSON"
+HOMEPAGE="
+ https://github.com/matrix-org/python-canonicaljson/
+ https://pypi.org/project/canonicaljson/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests unittest