summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 17:26:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 17:29:29 +0200
commit16323583566fcb0c5e2d95c5418dd5ab56b8d443 (patch)
tree3bf3edf7f5f76eb3989aa6912ed1ffce43eb505e /dev-python/cachelib
parentpackage.mask: Last rite dev-python/misaka (diff)
downloadgentoo-16323583566fcb0c5e2d95c5418dd5ab56b8d443.tar.gz
gentoo-16323583566fcb0c5e2d95c5418dd5ab56b8d443.tar.bz2
gentoo-16323583566fcb0c5e2d95c5418dd5ab56b8d443.zip
dev-python/cachelib: Enable py3.11
Closes: https://bugs.gentoo.org/896758 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cachelib')
-rw-r--r--dev-python/cachelib/cachelib-0.10.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/cachelib/cachelib-0.10.2-r1.ebuild b/dev-python/cachelib/cachelib-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..fa1018f6e406
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.10.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="
+ https://pypi.org/project/cachelib/
+ https://github.com/pallets-eco/cachelib/
+"
+SRC_URI="
+ https://github.com/pallets-eco/cachelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ net-misc/memcached
+ www-servers/uwsgi[python,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+ # requires some test server running
+ # (these tests require dev-python/boto3)
+ tests/test_dynamodb_cache.py
+)