summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-12-10 21:23:58 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-12-10 21:23:58 +0700
commit831013622624e3cf169c94015a8c65cf79f28a9f (patch)
treedef4992eab2cd26922cac22175e8c18534a61e1d /dev-python/bpython
parentprofiles/package.mask: last-rite www-apache/mod_caucho (diff)
downloadgentoo-831013622624e3cf169c94015a8c65cf79f28a9f.tar.gz
gentoo-831013622624e3cf169c94015a8c65cf79f28a9f.tar.bz2
gentoo-831013622624e3cf169c94015a8c65cf79f28a9f.zip
dev-python/bpython: remove old version
Package-Manager: Portage-3.0.29, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/bpython')
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.21.ebuild41
-rw-r--r--dev-python/bpython/files/bpython-0.21-fix-py3.10.patch48
-rw-r--r--dev-python/bpython/files/bpython-sphinx-4.patch8
4 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 57b9078d8607..82fee5093f84 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1,2 +1 @@
-DIST bpython-0.21.tar.gz 208206 BLAKE2B 22db7abe3786df337af50f6217fa8c6702871b50de41245797270e70622084a22b3d6615cfe634044599a532c5bc14677b01dc77042d228213eaae2cad11b623 SHA512 a0eea1b9c2329ce5665456e99703ef476faab38f880eb8a330a6536970888cfdaada9f0e377d3c1acd8b6c79eb0c562ada43e82bac9df4cce5878594c3399ddf
DIST bpython-0.22.1.tar.gz 217294 BLAKE2B 907b51753182add775d3e2ba08c3999d30ba23ab13d59f364d03ce5f22191e1a90031f7c3b5477fd00c94342a5ee204aa2618a7cd1a9470bbc898cfc266ba9bd SHA512 6b29235c41b645c3658812b8c80637d1e76029a6386f8628e5c681b2f3fdea653f89a12f4e28f55381464755e04fa7a33f023f096e75d889d5a588222c0d06c3
diff --git a/dev-python/bpython/bpython-0.21.ebuild b/dev-python/bpython/bpython-0.21.ebuild
deleted file mode 100644
index d815d9186569..000000000000
--- a/dev-python/bpython/bpython-0.21.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
-HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/curtsies-0.3.5[${PYTHON_USEDEP}]
- dev-python/cwcwidth[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/jedi[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- "
-# sphinx is used implicitly to build manpages
-BDEPEND="
- dev-python/sphinx[${PYTHON_USEDEP}]
- "
-
-DOCS=( AUTHORS.rst CHANGELOG.rst )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-sphinx-4.patch
- "${FILESDIR}"/${P}-fix-py3.10.patch
-)
-
-distutils_enable_sphinx doc/sphinx/source --no-autodoc
-distutils_enable_tests unittest
diff --git a/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch b/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch
deleted file mode 100644
index 5b7c63767820..000000000000
--- a/dev-python/bpython/files/bpython-0.21-fix-py3.10.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 78ead4c83d7c47c35ab075dd08114f51c24a709d Mon Sep 17 00:00:00 2001
-From: Thomas Ballinger <thomasballinger@gmail.com>
-Date: Wed, 6 Oct 2021 19:59:38 -0700
-Subject: [PATCH] Test Python 3.10 (#924)
-
-* Test Python 3.10
-* Update tests for Python 3.10
-
---- a/bpython/test/test_curtsies_painting.py
-+++ b/bpython/test/test_curtsies_painting.py
-@@ -139,6 +139,14 @@ def test_completion(self):
- "└──────────────────────────────┘",
- "Welcome to bpython! Press <F1> f",
- ]
-+ if sys.version_info[:2] < (3, 10)
-+ else [
-+ ">>> an",
-+ "┌──────────────────────────────┐",
-+ "│ and anext( any( │",
-+ "└──────────────────────────────┘",
-+ "Welcome to bpython! Press <F1> f",
-+ ]
- )
- self.assert_paint_ignoring_formatting(screen, (0, 4))
-
---- a/bpython/test/test_interpreter.py
-+++ b/bpython/test/test_interpreter.py
-@@ -35,7 +35,19 @@ def test_syntaxerror(self):
-
- i.runsource("1.1.1.1")
-
-- if sys.version_info[:2] >= (3, 8):
-+ if sys.version_info[:2] >= (3, 10):
-+ expected = (
-+ " File "
-+ + green('"<bpython-input-148>"')
-+ + ", line "
-+ + bold(magenta("1"))
-+ + "\n 1.1.1.1\n ^^^^^\n"
-+ + bold(red("SyntaxError"))
-+ + ": "
-+ + cyan("invalid syntax. Perhaps you forgot a comma?")
-+ + "\n"
-+ )
-+ elif (3, 8) <= sys.version_info[:2] <= (3, 9):
- expected = (
- " File "
- + green('"<input>"')
diff --git a/dev-python/bpython/files/bpython-sphinx-4.patch b/dev-python/bpython/files/bpython-sphinx-4.patch
deleted file mode 100644
index 5003de24bcf6..000000000000
--- a/dev-python/bpython/files/bpython-sphinx-4.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff -U2 -r bpython-0.21.orig/doc/sphinx/source/conf.py bpython-0.21/doc/sphinx/source/conf.py
---- bpython-0.21.orig/doc/sphinx/source/conf.py 2020-03-30 01:44:23.000000000 +0700
-+++ bpython-0.21/doc/sphinx/source/conf.py 2021-05-22 21:06:51.161746459 +0700
-@@ -215,3 +215,3 @@
- # If true, show URL addresses after external links.
- #man_show_urls = False
--
-+man_make_section_directory = False