summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 15:13:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 15:14:36 +0200
commit8db87b237340eff944724cc845318c0049e96b4d (patch)
treed7465d0bfb06984059eb0a3ec0d050ba09b73a61 /dev-python/bottle
parentdev-python/wsgiproxy2: Merge py3.13 revbump back (diff)
downloadgentoo-8db87b237340eff944724cc845318c0049e96b4d.tar.gz
gentoo-8db87b237340eff944724cc845318c0049e96b4d.tar.bz2
gentoo-8db87b237340eff944724cc845318c0049e96b4d.zip
dev-python/bottle: Merge py3.13 revbump back
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/bottle-0.12.25-r1.ebuild9
-rw-r--r--dev-python/bottle/bottle-0.12.25-r2.ebuild55
2 files changed, 7 insertions, 57 deletions
diff --git a/dev-python/bottle/bottle-0.12.25-r1.ebuild b/dev-python/bottle/bottle-0.12.25-r1.ebuild
index 6c0982822759..79a2de881ca8 100644
--- a/dev-python/bottle/bottle-0.12.25-r1.ebuild
+++ b/dev-python/bottle/bottle-0.12.25-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 optfeature pypi
@@ -19,6 +19,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/legacy-cgi[${PYTHON_USEDEP}]
+ ' 3.13)
+"
BDEPEND="
test? (
dev-python/mako[${PYTHON_USEDEP}]
diff --git a/dev-python/bottle/bottle-0.12.25-r2.ebuild b/dev-python/bottle/bottle-0.12.25-r2.ebuild
deleted file mode 100644
index 8269bb9ec812..000000000000
--- a/dev-python/bottle/bottle-0.12.25-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="A fast and simple micro-framework for small web-applications"
-HOMEPAGE="
- https://bottlepy.org/
- https://github.com/bottlepy/bottle/
- https://pypi.org/project/bottle/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/legacy-cgi[${PYTHON_USEDEP}]
- ' 3.13)
-"
-BDEPEND="
- test? (
- dev-python/mako[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/bottlepy/bottle/issues/1422
- "${FILESDIR}/${P}-py312.patch"
-)
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- sed -e '/scripts/d' -i setup.py || die
-
- # Remove test file requiring connection to network
- rm test/test_server.py || die
- distutils-r1_python_prepare_all
-}
-
-pkg_postinst() {
- optfeature "Templating support" dev-python/mako
- elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
- elog "we do as most other distros and do not install the script anymore."
- elog "If you do want/have to call it directly rather than through your app,"
- elog "please use the following instead:"
- elog ' `python -m bottle`'
-}