summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 04:37:13 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 05:54:36 +0200
commit8525c51d16f65977947810cddea56a7bcdaaac33 (patch)
tree060ac532ebb1abd0680c35b8a94e0de0d6b52a0f /dev-python/boto3
parentdev-python/botocore: Bump to 1.29.161 (diff)
downloadgentoo-8525c51d16f65977947810cddea56a7bcdaaac33.tar.gz
gentoo-8525c51d16f65977947810cddea56a7bcdaaac33.tar.bz2
gentoo-8525c51d16f65977947810cddea56a7bcdaaac33.zip
dev-python/boto3: Bump to 1.26.161
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.161.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c4f62f1c05b5..c6287cc0303c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -10,3 +10,4 @@ DIST boto3-1.26.157.gh.tar.gz 666162 BLAKE2B ad80278fed9022dabb77879cca15cb7abf2
DIST boto3-1.26.158.gh.tar.gz 667274 BLAKE2B e507fc9d404fabeb179524408c883ae5311c2273d838d7270eb60aa0c13e4f8faa3fe0ae4dc58566ba8f61764d171c3b012906e6d5ff91e1e958d5fb6ea2936e SHA512 ff70265a03fd29de37f7cc328c2ab277483390f27977f36fca5199ac2b10d978f5ef4db1504f12da4f3d1453fb7051375784cbc840ec3be7f161c6a42c44c1a4
DIST boto3-1.26.159.gh.tar.gz 667712 BLAKE2B 6604ba81b3c52dba19d31a92b8e800958abbc5927f6513eff688c7dacb7db9f16927402336113a33a4a8d6da9440b1f91323b18957be77137eff351aae3ef550 SHA512 a5ba427bb5b5cd3e60b668cd4f9923ddf4f5e3341aa219a599c1b15b27bc22d6c6e3a07b38e75ad302cd15ecb3e2bfd42570e7bd4007929345b9f61eb3a853fe
DIST boto3-1.26.160.gh.tar.gz 667890 BLAKE2B 2d081604ea94a6fece2c6839c0be339fa2ff3f8c4eba5b882eb45597646ef8efc0294abb58f9233e3fe1ec445131a91701ddf8771220275c13c34af9813cd8e6 SHA512 2a427e63fc61581a873a75ea2b0fe4329cc55ea61e7c99049d8d24c3cb676490a66efa9d6236b90ba6d7c41208a90a60b04dac53ff8243952d64134abff4ba82
+DIST boto3-1.26.161.gh.tar.gz 668281 BLAKE2B 3c0500449c202c385e1f4aa3c29b41e166756ebad344257beed5dbfd9c3ca6bee19b8d6c9338f4bd34242613968a4bf074158d267c74b62d3d8d5f47b8aef188 SHA512 91c8f43b47b5b2a67e58a14924dd436e2f07b6a14d2a3b9698d7e63d140db98a96af9856a3b11b95e87ea232f5b250378f303acc7d756daac9eab3ad17180c12
diff --git a/dev-python/boto3/boto3-1.26.161.ebuild b/dev-python/boto3/boto3-1.26.161.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.161.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}