summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 06:34:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 07:34:47 +0200
commit351c81d879152f165ccf42453dd5d084192492a4 (patch)
tree83a7b4157a4a44367642a77b6c5ffd7d9d554a7b /dev-python/boto3
parentdev-python/botocore: Bump to 1.29.137 (diff)
downloadgentoo-351c81d879152f165ccf42453dd5d084192492a4.tar.gz
gentoo-351c81d879152f165ccf42453dd5d084192492a4.tar.bz2
gentoo-351c81d879152f165ccf42453dd5d084192492a4.zip
dev-python/boto3: Bump to 1.26.137
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.137.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index cb2b23cdbf4f..85a89c434769 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,3 +9,4 @@ DIST boto3-1.26.133.gh.tar.gz 648114 BLAKE2B 97c71216d92baffb9e07f9c112590a1fc78
DIST boto3-1.26.134.gh.tar.gz 649039 BLAKE2B ac6c136c363fd14c373acdd5f1af2bb46b77fae74a5f633f87748ebebeeff8cbfcb3ed62874b255d9dea0824d565149dc0b9cf02f6a596e5b2278b77a479a4bc SHA512 195ae53f705bbc3cb801b4b8425071a796fdf6dabaf8f68d0fc4ec9e216cdbf5def719cc5a7f537f8a075bd5bd8a5d1aca35422d359b471c35dc58af04a63407
DIST boto3-1.26.135.gh.tar.gz 649517 BLAKE2B fbc1d4bda5ac932569ca26a17146ce9ca7e5f238b0f3465f1be8c35a26e07fe9649951f2d2bffd574d34239569b73510ca414ca92563d08a021c5aa968745650 SHA512 468a07a448b5aa76a437e6c56dcfc3d198bf28647c744a14f76946b889583bc24cb802a26386ddff449aea2731b2cfbfb859e6fecaa3ef05512bf4d33b9e476e
DIST boto3-1.26.136.gh.tar.gz 650400 BLAKE2B 973b78276ab19b4607bb7b1909c91336f47219e097a385d34bc6529d8e97cfdef56447dc5760cbed5440d79b429f7b8c27bc38c00168d39b3c514657e06361c2 SHA512 c4eeb3bf5b5d7adb0cb2f81329984dda4f4f34eb123a875012d9ee874de4429a80d6834fe489691a9090b075815b0fe419b09884f9a2dfeb761ecc909db8241d
+DIST boto3-1.26.137.gh.tar.gz 650777 BLAKE2B e4a7d02ccefbda53b33558dc107457eaa1df0871bb2fc548b348246192cfdd6760bc43a6e6861622de6376244b80a94a387bbb827be2f5b749bccf6b8ff5af58 SHA512 de5d29a4139650f0527e93a9e223b7d41b285b6c263a5bc7ec9ebad1eee19373b1f2093c03414f7b575f8a7402734b4076cfaf0fa5be34ff54b55d8960e9c836
diff --git a/dev-python/boto3/boto3-1.26.137.ebuild b/dev-python/boto3/boto3-1.26.137.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.137.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}