summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-28 04:42:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-28 04:42:03 +0200
commit0ae5c73761f8e889d6f9355cab236349f3d6e440 (patch)
tree8e1727f1be3cb9209f628c4c27f0fb4efd5a5ec4 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.7 (diff)
downloadgentoo-0ae5c73761f8e889d6f9355cab236349f3d6e440.tar.gz
gentoo-0ae5c73761f8e889d6f9355cab236349f3d6e440.tar.bz2
gentoo-0ae5c73761f8e889d6f9355cab236349f3d6e440.zip
dev-python/boto3: Bump to 1.35.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.7.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 956f6d4088e7..7e868a62ef51 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.34.158.gh.tar.gz 848930 BLAKE2B 5db04b9eee08f5418a595e736f075fbe22b
DIST boto3-1.35.0.gh.tar.gz 851637 BLAKE2B 485b17616fed53a88280aad92d2e4219d8bcbf469b42cff6113f9596c6b245fad39b403b4fb29ed99b50955baa50940091e9c0f88cc6e350b44c69c4b1df5fdc SHA512 0236748c667ef1baf7484d4808083cb517c19ceae672973ac0cf9ce509a9e4a965c15349876807dc320fc96210ba6c5d16ea66545de19eed33dace058392d85d
DIST boto3-1.35.5.gh.tar.gz 854016 BLAKE2B f94d738e310725cd5f9c7b405a094155f3ecf640f02045662ed94ab3689ea549fde7eee19ae2be450768560ad705b8740fda78b79ed42cf536231626d247e09a SHA512 fc1106abbb306bacb80dce825bf71303e71b0d0698d7e3bb4dcaca4ea6e4f7a97e70753367200294f334b351e764bca57f2316afec854d2e46db4644dfefc25b
DIST boto3-1.35.6.gh.tar.gz 854351 BLAKE2B 0aea780d070a5a806bcb8196ebc3785eb1a1b5ad3cb9f1598a24bf80b4be5f8757b551a524afed9440deae505e427b97f9b79b1a7c30c7db977319ee317bb58c SHA512 81fce9301003a5b2f67107a7f6ebbd033a43a43c890be7ff3248136c1fcc826fd475f9860d3295f16900f199057e1a7da7be60554dc193826ecef6e64f97341d
+DIST boto3-1.35.7.gh.tar.gz 854615 BLAKE2B 4cf4fd926bc4175273df2007f1275e0781c199361cb8c419c7c34bc764e47d0c74f7f9c9de8d25a7052072a73ccdf0c3d2ec7fcab5b71a4107b2c22a1eef5700 SHA512 4e85d9d2004d6d74190f560b41cb6a4ace30b3ce4d09d5b390045874bedca1d0fc1756170bf81f615c81a371038fa7a94c407a3de417c0be6b33805bd32866e1
diff --git a/dev-python/boto3/boto3-1.35.7.ebuild b/dev-python/boto3/boto3-1.35.7.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}