summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-13 05:12:47 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-13 05:12:47 +0200
commit07842c657b15c47f22351dbefe6abf7c87e2fa0d (patch)
tree336bfd74347ee33602efa6af06d65084260754f4 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.125 (diff)
downloadgentoo-07842c657b15c47f22351dbefe6abf7c87e2fa0d.tar.gz
gentoo-07842c657b15c47f22351dbefe6abf7c87e2fa0d.tar.bz2
gentoo-07842c657b15c47f22351dbefe6abf7c87e2fa0d.zip
dev-python/boto3: Bump to 1.34.125
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.125.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b1af8ed49927..5923f3ad1960 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.34.117.gh.tar.gz 813596 BLAKE2B 1b68c6410a9e4859c05ec6e8baa7b4d0a8e
DIST boto3-1.34.122.gh.tar.gz 817093 BLAKE2B ecc91833d5d8b7ae33c2fe435e33bc8fa236388dcd36bbbfad138e72dcada1018d9fe032a04565bc6ba04f252c5b1e066f650620aab2b6682705d164660eaa9b SHA512 26ece26e24a09ce12f57fd7cbede798446ddb60c28dd7d090c2604b71cc92fca9cfdc268e6d65fad1bcecf161976186b21acefdb70a2de8acaccd85567a388d0
DIST boto3-1.34.123.gh.tar.gz 817520 BLAKE2B 264464edc80ec43c6759b542629bfbaa1a7212a67d6738b920191f52be9a51bf6c16170de161f2299273cb5ac3e15dc8c74e60aff8212e51408343362f275f8f SHA512 4b90e3534e0319932bd038a23e68a2dd913fe99f0d07df23f2a1dd4ac8fca7c6f614e7cbc3359851e575599c386c89f382c439f712956e9190872d610b8f6c04
DIST boto3-1.34.124.gh.tar.gz 818934 BLAKE2B ab1ae5af51340c1782af93c7bbcd88960331449e1372cd614b8905fd8e04d3d2f10a3b92c49938dc101e543525fc85a95dba8ec774d0eb91fbb832ac54288979 SHA512 c49aaf78e1f539e5af32252d645de28f1126e35f4d3603107a3b1329c1cb1d5578c005d678d05e3d0c907c3ef098485113982292bce5168cd4679727797f210d
+DIST boto3-1.34.125.gh.tar.gz 819606 BLAKE2B c1213b7da4c5c249f4c886e4adf56466242ca0cc73c0ee3e484983f8c18627ecc7414c8465a6e61c5f135169cbd01386f62d5f386e021ab70cf62b8d603bba6c SHA512 5a8ad7e9d7e6daa311f450b1c49894858dffcdef7504deeb8aad871dc171522776dfa9ae1097365e5ffa039d5987a30de481d748a57f6f2d949ac268774325ec
diff --git a/dev-python/boto3/boto3-1.34.125.ebuild b/dev-python/boto3/boto3-1.34.125.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.125.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}