summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 09:44:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 09:44:14 +0200
commitca7eb62af428a216f661d340fbccf4772cfea088 (patch)
tree1b5667a903772f4a7b522987fa67b0be927302ed /dev-python/bibtexparser
parentdev-python/objgraph: Enable py3.11 (diff)
downloadgentoo-ca7eb62af428a216f661d340fbccf4772cfea088.tar.gz
gentoo-ca7eb62af428a216f661d340fbccf4772cfea088.tar.bz2
gentoo-ca7eb62af428a216f661d340fbccf4772cfea088.zip
dev-python/bibtexparser: Strip obsolete future dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bibtexparser')
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.2.0-r2.ebuild (renamed from dev-python/bibtexparser/bibtexparser-1.2.0-r1.ebuild)14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/bibtexparser/bibtexparser-1.2.0-r1.ebuild b/dev-python/bibtexparser/bibtexparser-1.2.0-r2.ebuild
index 0d1dd2ae0417..656fb45a6c81 100644
--- a/dev-python/bibtexparser/bibtexparser-1.2.0-r1.ebuild
+++ b/dev-python/bibtexparser/bibtexparser-1.2.0-r2.ebuild
@@ -5,10 +5,14 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
-DESCRIPTION="A BibTeX parser written in python"
-HOMEPAGE="https://github.com/sciunto-org/python-bibtexparser"
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
SRC_URI="
https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -19,7 +23,9 @@ LICENSE="|| ( BSD LGPL-3 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
@@ -27,5 +33,7 @@ src_prepare() {
# fixed in upstream 5f98bac62e8ff3c8ab6b956f288f1c61b99c6a5d
sed -e 's:unittest2:unittest:' \
-i bibtexparser/tests/test_crossref_resolving.py || die
+ # remove obsolete dep
+ sed -i -e "s:'future>=0.16.0'::" setup.py || die
distutils-r1_src_prepare
}