summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2019-07-03 22:43:23 +0200
committerJonas Stein <jstein@gentoo.org>2019-07-03 22:43:23 +0200
commit9dfa6e22bb654ac2052e1e4d199994614c1ae8d9 (patch)
tree072aba876d49cf63f25d9c74f197e078eaca93d3 /dev-python/bibtexparser
parentdev-python/bibtexparser: Update License (diff)
downloadgentoo-9dfa6e22bb654ac2052e1e4d199994614c1ae8d9.tar.gz
gentoo-9dfa6e22bb654ac2052e1e4d199994614c1ae8d9.tar.bz2
gentoo-9dfa6e22bb654ac2052e1e4d199994614c1ae8d9.zip
dev-python/bibtexparser: Version bump to 1.1.0
Version bump to 1.1.0 and EAPI=7 Package-Manager: Portage-2.3.68, Repoman-2.3.14 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'dev-python/bibtexparser')
-rw-r--r--dev-python/bibtexparser/Manifest1
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/Manifest b/dev-python/bibtexparser/Manifest
index 26d7af1f8820..a2670d3c1936 100644
--- a/dev-python/bibtexparser/Manifest
+++ b/dev-python/bibtexparser/Manifest
@@ -1 +1,2 @@
DIST bibtexparser-0.6.2.tar.gz 50876 BLAKE2B 660508717a224d1c1c28a52c8d7ccc8de7248e61b45ce73bb46729ee7feb8872bdaf92bd6b07cdfb7934fa57993b39749b9961185d4dc9cec2d55809761a783e SHA512 43a1c0475bc9e97c201a850e944f082e9eb316ac475cce4128b821008fc5b1597317f28c594f5462daee992b455fb4254fdf76a5baa02ff8e8a0e36f43c52491
+DIST bibtexparser-1.1.0.tar.gz 88656 BLAKE2B e5285953fbf79558643e19ea39f6421394f93afbfc6820be9bee0583c1efa010b9fe3478c9f3e36bea0c64e35c9d5bcb8341f1ee784c4150883e160723b94119 SHA512 f984cb307bfb8ee8143499469c0a83a28b3e9f061b17e5b43b7f9aa730c91427f2b2c441e501d37ab62f99ce2b7dd1cd7dee40b21c9f1a8e8b2dddf8eac2e74b
diff --git a/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild b/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild
new file mode 100644
index 000000000000..9d0a491d8df9
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="A BibTeX parser written in python"
+HOMEPAGE="https://github.com/sciunto-org/python-bibtexparser"
+SRC_URI="https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/python-${P}"
+
+src_test() {
+ python_foreach_impl nosetests
+}