summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-26 06:09:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-26 06:39:11 +0100
commit7c4a6e42a6a4e0c3bdbb56772afe456a176950a7 (patch)
tree2ca9aa1cb3da5f8de13d76177db10efbe38bc1ac /dev-python/beartype
parentdev-python/hypothesis: Bump to 6.97.0 (diff)
downloadgentoo-7c4a6e42a6a4e0c3bdbb56772afe456a176950a7.tar.gz
gentoo-7c4a6e42a6a4e0c3bdbb56772afe456a176950a7.tar.bz2
gentoo-7c4a6e42a6a4e0c3bdbb56772afe456a176950a7.zip
dev-python/beartype: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beartype')
-rw-r--r--dev-python/beartype/Manifest1
-rw-r--r--dev-python/beartype/beartype-0.17.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index 03751847b826..3a029ceae167 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1 +1,2 @@
DIST beartype-0.16.4.tar.gz 1063638 BLAKE2B a5e399f070cb0e7b9046eeb66f98d5ea194482d9d10db0f63269f2f085ad30c5a103dbb4f4f6e167fef56c348e9de63bd9c70812170c159d9b913235cf769bd9 SHA512 377bf525bdbc46879b2b864289d0450ec7835e424c3d31b682b4d9460f0d65f9759e4e1dc3e6e9b42047f7555ae7dfa8e7598d2181d25c94f30e01f7d006a741
+DIST beartype-0.17.0.tar.gz 1127446 BLAKE2B af31894aab2d2482d288832b59859c9f1ccebd21f9e974e18a68f132c2e4c5194d46e4323ed6b8ec2b1804977672cf72d3357ca04b910a6d2ad968bfdf2b1bb7 SHA512 b1322e640f1482819fa8218d284acd1ccb7063e1d725b5db9d3e71a762d4c464ad138df10ec24a3ead07105fb3d24336635309498ea8ce3c811c26a5ee457252
diff --git a/dev-python/beartype/beartype-0.17.0.ebuild b/dev-python/beartype/beartype-0.17.0.ebuild
new file mode 100644
index 000000000000..2cda7e3f1e70
--- /dev/null
+++ b/dev-python/beartype/beartype-0.17.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a70_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}