summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-24 09:21:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-24 09:29:02 +0200
commitdcfb4ca09a324a41b24bd03a2a78e62974a466ce (patch)
treeae1b50eeaeb9700d19470a4dbfcf2b6ab1886f06 /dev-python/autopep8
parentx11-themes/gnustep-neos-theme: port to EAPI 7 (diff)
downloadgentoo-dcfb4ca09a324a41b24bd03a2a78e62974a466ce.tar.gz
gentoo-dcfb4ca09a324a41b24bd03a2a78e62974a466ce.tar.bz2
gentoo-dcfb4ca09a324a41b24bd03a2a78e62974a466ce.zip
dev-python/autopep8: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.6.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 6d6433b471a7..203514e99e97 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1,2 @@
DIST autopep8-1.5.7.tar.gz 121537 BLAKE2B 06f107cab210258fe71b8e912312520797122fd38e3e67fa0d6cf640806690e1255fec63c74c11ec39952a4a50964a3f622ca1166d29299c4f7a7031a1013202 SHA512 b8fb8b63400e74ea978f576cb47c99b0a4bb15a5d1cfeb6ffc25d2ecdad301762f99ddff5c75af3900b3560797d9289a15bbb87ddcf74077d39bde0abadd4da7
+DIST autopep8-1.6.0.tar.gz 122165 BLAKE2B 606ccf7ab51b52db95287384f9b19fd0f72da9e8fb4537bf395651622a95f88d782679550e61816d60dd3faa2fa096c979575d60cbd95476fa1cd7cf2c4f4180 SHA512 f4ffd564ceb48ff1f37d0a051aa8fefc60595a68709045c13561d8ab73de48dce99cc12acf40559e587ba4f6fddd4727dd2b40691ce43c991d60dda2c8b0d617
diff --git a/dev-python/autopep8/autopep8-1.6.0.ebuild b/dev-python/autopep8/autopep8-1.6.0.ebuild
new file mode 100644
index 000000000000..54be24f31921
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest