summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-28 07:54:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-28 09:08:49 +0200
commit5d4ecf2bee673b7cbcb26a23cefd8084d70c27ff (patch)
treed5e32fb869fc82316e3ca6ffeb615a7a5b498027 /dev-python/autopep8
parentdev-python/jsonref: Bump to 1.0.0 (diff)
downloadgentoo-5d4ecf2bee673b7cbcb26a23cefd8084d70c27ff.tar.gz
gentoo-5d4ecf2bee673b7cbcb26a23cefd8084d70c27ff.tar.bz2
gentoo-5d4ecf2bee673b7cbcb26a23cefd8084d70c27ff.zip
dev-python/autopep8: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.7.1.ebuild42
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild20
3 files changed, 59 insertions, 4 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 73e96699c4a9..d4bf51b8710f 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1,3 @@
DIST autopep8-1.6.0.tar.gz 122165 BLAKE2B 606ccf7ab51b52db95287384f9b19fd0f72da9e8fb4537bf395651622a95f88d782679550e61816d60dd3faa2fa096c979575d60cbd95476fa1cd7cf2c4f4180 SHA512 f4ffd564ceb48ff1f37d0a051aa8fefc60595a68709045c13561d8ab73de48dce99cc12acf40559e587ba4f6fddd4727dd2b40691ce43c991d60dda2c8b0d617
DIST autopep8-1.7.0.tar.gz 117055 BLAKE2B 36e2789551eb671b0bc7481742d9edf25aa622bd3f605fb2491195c45f7630378116e4b0bffb536cf7596b3b1c5ea695796259b944a886d55f05c9891e280d0c SHA512 e93ddf90ff989af71790f70f7e7101f7cc60890c8a976552a097c13b0a0e10c16dfd8770214b19d7fabd59403e6d87a9a37d75a2c6f3ed27f8c82a7d8da95dad
+DIST autopep8-1.7.1.tar.gz 117449 BLAKE2B 27bfdc58f647f3f2a7c3945f7faee152667e1dffc13c2b4a5af1f74e7d544c21d1472dc34c797818ca45fccae9f53e7a333c71b52b825b0fb97b50f12567889b SHA512 7a4a8ebf0bacd781fdf7ae32a34bd64f5b6ba9e8ccef5709799cefe5e5bc24da47f36ea49092e26a7c3e254bbea5d6feaeca38f64ffc3fe440307b1331be4766
diff --git a/dev-python/autopep8/autopep8-1.7.1.ebuild b/dev-python/autopep8/autopep8-1.7.1.ebuild
new file mode 100644
index 000000000000..b201d023a72a
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test require in source build
+ test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
+)
+
+PATCHES=(
+ "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
+)
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index bb50e6c643bd..b201d023a72a 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -3,14 +3,17 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
inherit git-r3
@@ -23,8 +26,17 @@ LICENSE="MIT"
SLOT="0"
RDEPEND="
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
dev-python/tomli[${PYTHON_USEDEP}]
"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test require in source build
+ test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
+)
+
+PATCHES=(
+ "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
+)